Closed Bug 1576268 Opened 5 months ago Closed 5 months ago

[Wayland] Dragging a tab to another window duplicates it rather than moving it

Categories

(Core :: Widget: Gtk, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla70
Tracking Status
firefox70 --- verified

People

(Reporter: botond, Assigned: stransky)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

STR

  1. Run Firefox Nightly with MOZ_ENABLE_WAYLAND=1. I am testing on Debian 10 with GNOME.
  2. Open a second browser window.
  3. Open a new tab in the first browser window and navigate to a website.
  4. Drag the tab from the first window to the second.

Expected results

The tab is moved to the new window.

Actual results

The tab is duplicated to the new window. That is, a tab with the same website opens in the new window, but the original tab sticks around in the old window.

I also see (intermittently) blank tabs instead of duplication.

Yes, it's because Wayland default action is Copy and X11 default action is Move. You can change it by "Shift" key during the D&D. We may consider to change that to keep X11 compatibility.

FWIW, dragging a tab in Wayland GNOME Web moves the tab (does not copy).

(In reply to Asif Youssuff from comment #3)

FWIW, dragging a tab in Wayland GNOME Web moves the tab (does not copy).

Okay, let's fix that in Firefox too.

Assignee: nobody → stransky
Keywords: checkin-needed

Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe6f7a136d06
[Wayland] Use MOVE as a default Drag and Drop action to match X11 behavior, r=jhorak

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
Duplicate of this bug: 1532618
Duplicate of this bug: 1466444

Has this fix reached nightly?? I use the aug 29 one and when i drag a tab within the same window it still gets copied instead of moved?

Duplicate of this bug: 1562599

I can verify this is fixed in latest Nightly (2019-08-29) with Wayland backend on Ubuntu 19.04. The default drag behavior is move and pressing Ctrl switches to copy.

Status: RESOLVED → VERIFIED

@Kestrel

Can you check the within the same window drag behavior??? Ie. open two/three tabs and try to rearrange them.

Rearranging tabs by drag and drop within the same window moves them by default for me (as it was before), this bug only manifested when dragging outside the tab strip (Bug 1532618).

Unless there is a setting i am missing somewhere trying to rearrange tabs copies them. Dragging from one window to another works fine.

Weston as a compositor.

(In reply to ApB from comment #15)

Unless there is a setting i am missing somewhere trying to rearrange tabs copies them. Dragging from one window to another works fine.

Weston as a compositor.

Please open a new bug for it specifically for Weston. This is a bit tricky and depends on the actual compositor.

(In reply to Martin Stránský [:stransky] from comment #16)

(In reply to ApB from comment #15)

Unless there is a setting i am missing somewhere trying to rearrange tabs copies them. Dragging from one window to another works fine.

Weston as a compositor.

Please open a new bug for it specifically for Weston. This is a bit tricky and depends on the actual compositor.

The thing is that we have around 5 (???) different compositors and FF should work the same way on all of them.

You need to log in before you can comment on or make changes to this bug.