Cannot display extended characters in GUI (menus, toolbars, etc.)

VERIFIED FIXED in Chimera0.4

Status

Camino Graveyard
Bookmarks
--
major
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Stephane Moureau, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({intl})

unspecified
Chimera0.4
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

16 years ago
If you add a bookmark with extended/accentuated characters (eg. ç = ccedil;) in
its name, those characters are shown as a black square in the Bookmarks menu and
as a 'space' in the sidebar bookmarks list.

Comment 1

16 years ago
Confirmed using Chimera/20020619. Is bug 150924 the catch-all "internationalize
Chimera" bug, or do we need to create one of those?
Severity: normal → major
Keywords: intl
Summary: Extended chars as black squares in menus → Cannot display extended characters in GUI (menus, toolbars, etc.)

Comment 2

16 years ago
->pinkerton, sounds like a Cocoa limitation?
Assignee: saari → pinkerton
(Assignee)

Comment 3

16 years ago
hyatt did a lot of bad things in the bm code. i'll fix it
Status: NEW → ASSIGNED
Target Milestone: --- → Chimera0.4

Comment 4

16 years ago
As bug 150924 works fine, Japanese pages are dispalyed well.
But this bug hasn't been fixed yet.

When I file a Japanese titled page as a bookmark item,
it is shown as garbage in menu and sidebar.
But, I edit the item's name and restarted Chimera,
it is displayed fine in both menu and sidebar.

Comment 5

16 years ago
*** Bug 156893 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
I'd like to note that this bug also causes corruption of the bookmarks file, not
just invalid UI. Bug #156893 which was marked as a duplicate of this bug had a
more verbose description of the issue.
(Reporter)

Comment 7

16 years ago
This site http://www.jp.redhat.com/ does not even enter the bookmark.
Cmd-D, ok, nothing !
(Assignee)

Comment 8

16 years ago
i can type in ç's and é's, but then again, i could many revisions ago before i
fixed a bunch of problems.

can someone give me a concrete testcase with, say, japanese chars in the title?
(Assignee)

Comment 9

16 years ago
found one...http://quote.yahoo.co.jp/

i think i've got this licked. Japanese is so pretty ;)
(Assignee)

Comment 10

16 years ago
i think this is now fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
I agree this is fixed.

Comment 12

15 years ago
verified with 07-29 build on OS 10.1.5.

Verified that traditional Chinese, simplified Chinese, Japanese, and Korean
characters display properly in title bars, menus items, and sidebar. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.