Unable to load OpenH264 plugin on Android

RESOLVED FIXED in Firefox 66

Status

()

defect
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: dminor, Assigned: dminor)

Tracking

({regression})

66 Branch
mozilla67
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66+ fixed, firefox67+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 months ago

I see the following error in logcat:

03-05 14:51:59.416 794 3845 W ActivityManager: Unable to start service Intent { cmp=org.mozilla.fennec_aurora/org.mozilla.gecko.process.GeckoServiceChildProcess$gmplugin } U=0: not found

Mozregression points to:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=51c86d025ecb710b8d37d3454a1d0adcfff8f89d&tochange=de7c04ff60015787b787416797252148902e4bfb

de7c04ff6001 Nathan Froyd — Bug 1514044 - part 3 - update nsICrashService process constants and add checks for them; r=gsvelto
65f142863701 Nathan Froyd — Bug 1514044 - part 2 - change CrashReporterHost to use GeckoProcessTypes.h; r=gsvelto
1abd03bcbfa3 Nathan Froyd — Bug 1514044 - part 1 - macro-ify process enums, strings, and XRE functions; r=mccr8
6d7562d60590 Nathan Froyd — Bug 1514043 - change gecko media plugin process name; r=mccr8,bobowen,haik,chutten

I tested this using https://mozilla.github.io/webrtc-landing/pc_test.html, select "Require H.264 video" and de-select "Enable Identity Provider". On affected versions of Firefox, you will only see the local video in each video element. On working versions of Firefox, you will see both local and remote videos in each video element.

Due to Bug 1532578, I was not able to test versions of Firefox after Bug 1527811 landed, so I guess it's possible this has been fixed since then.

(Assignee)

Comment 1

3 months ago

[Tracking Requested - why for this release]:

This is a recent regression that would prevent us from using OpenH264 on Android.

Flags: needinfo?(nfroyd)

Ugh. Do we have to fix 66, given that bug 1532578 isn't going to be fixed for 66?

snorp, do I just have to update https://searchfox.org/mozilla-central/source/mobile/android/geckoview/src/main/java/org/mozilla/gecko/process/GeckoServiceChildProcess.java#144 for the new name, and then magic will just make things work?

Flags: needinfo?(nfroyd) → needinfo?(snorp)
(Assignee)

Comment 3

3 months ago

Bug 1532578 only affects Firefox 67, so it would be good to have a fix for 66.

(Assignee)

Comment 4

2 months ago

It is also necessary to update a few manifest files.

Assignee: nobody → dminor
Status: NEW → ASSIGNED
Flags: needinfo?(snorp)
(Assignee)

Comment 5

2 months ago

In Bug 1514043 we renamed the geckomediaplugin to gmplugin, but missed renaming
it on Android. This prevents the plugin from loading, which breaks OpenH264 in
WebRTC.

Comment 6

2 months ago
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e038e06397ad
Rename geckomediaplugin to gmplugin on Android; r=droeh

Comment 7

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
(Assignee)

Comment 8

2 months ago

Comment on attachment 9049180 [details]
Bug 1532756 - Rename geckomediaplugin to gmplugin on Android; r=droeh!

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1514043
  • User impact if declined: Unable to use openh264 on Android, which would break webrtc services which only support H.264.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk, only code changes are to rename the plugin.
  • String changes made/needed: None.
Attachment #9049180 - Flags: approval-mozilla-beta?

Comment on attachment 9049180 [details]
Bug 1532756 - Rename geckomediaplugin to gmplugin on Android; r=droeh!

We probably shouldn't break WebRTC on mobile.
OK to uplift for the RC build.

Attachment #9049180 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Is there anything we can add to automated tests to catch this in future?

Flags: needinfo?(dminor)
Flags: in-testsuite?
(Assignee)

Comment 12

2 months ago

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #10)

Is there anything we can add to automated tests to catch this in future?

At the moment we don't run any openh264 tests on Android at all. We have Bug 1355786 on file for that. We also have Bug 1462786 to use the real OpenH264 plugin which might help things, as I don't think we're building the "fake" h264 plugin for Android.

Flags: needinfo?(dminor)
Flags: in-testsuite?
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.