Contextmenu of keyword search field background-color is transparent

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
3 months ago

People

(Reporter: alice0775, Assigned: vporof)

Tracking

({nightly-community, regression})

67 Branch
mozilla67
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67+ verified)

Details

Attachments

(2 attachments)

Reporter

Description

4 months ago
Posted image image.png

Reproducible: always

Steps to reproduce:

  1. Open about:preferences > Search
  2. Attempt to edit keyword search
  3. Right click on the keyword editing field

Actual Results:
Contextmenu background is transparent. See attached screenshot

Reporter

Comment 1

4 months ago

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1657fe18be9bc445c7838e3b4e93a9bfc4f85e7f&tochange=a6606e85276716b93695029cb914a678beb51708

Regressed by:
a6606e852767 Victor Porof — Bug 1523957 - Convert trees to custom elements, r=bgrins, mak, standard8, MattN

Victor,
Your patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(vporof)
Assignee

Comment 2

4 months ago

Will do, thanks!

Keeping ni?.

[Tracking Requested - why for this release]:
Usability regression in nightly that we shouldn't ship.

Priority: -- → P1
Has Regression Range: --- → irrelevant
Has STR: --- → yes

Victor, are you working on this bug and should it be moved to Toolkit::XUL Widgets since this was regressed by Bug 1523957? This is a P1 tracked regression for 67 and we should probably fix that as soon as possible. Thanks

Has Regression Range: irrelevant → yes

Comment 5

4 months ago

Another STR:

  1. Click star in the URL bar to add a bookmark
  2. Click down arrow next to folder dropdown
  3. Click New Folder
  4. Right click the selected "New Folder" text
Assignee

Comment 6

4 months ago

Having a closer look asap!

Assignee: nobody → vporof
Status: NEW → ASSIGNED
Flags: needinfo?(vporof)
Component: Preferences → XUL Widgets
Product: Firefox → Toolkit

Comment 8

3 months ago
Pushed by vporof@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/72c8227148dd
Contextmenu of keyword search field background-color is transparent, r=mossop

Comment 9

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Comment 10

3 months ago

Fixed on latest Nightly.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1533739
You need to log in before you can comment on or make changes to this bug.