Status

enhancement
P3
normal
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

(Blocks 1 bug)

unspecified
Firefox 67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 months ago

We should run yarn lint in the try test so that our JS, CSS, and MD is linted.

Assignee

Updated

3 months ago
Summary: Lint on try → Lint Debugger on try
Assignee

Updated

3 months ago
Priority: -- → P3

Comment 2

3 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d5db39b0497
Lint Debugger on try. r=davidwalsh

Backed out for debugger failures

backout: https://hg.mozilla.org/integration/autoland/rev/c84fd846abe142b628e1c8bcd2144c7c4f21983c

push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=5d5db39b04977e9095ecc25bb66d5438010d0cf0&searchStr=linux%2Cx64%2Copt%2Cnode%2Ctests%2Csource-test-node-debugger-tests%2Cnode%28debugger%29

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=232744085&repo=autoland

[task 2019-03-08T20:21:28.787Z]
[task 2019-03-08T20:21:28.787Z] Oops! Something went wrong! :(
[task 2019-03-08T20:21:28.788Z]
[task 2019-03-08T20:21:28.788Z] ESLint: 5.9.0.
[task 2019-03-08T20:21:28.788Z] ESLint couldn't find the plugin "eslint-plugin-no-unsanitized". This can happen for a couple different reasons:
[task 2019-03-08T20:21:28.788Z]
[task 2019-03-08T20:21:28.788Z] 1. If ESLint is installed globally, then make sure eslint-plugin-no-unsanitized is also installed globally. A globally-installed ESLint cannot find a locally-installed plugin.
[task 2019-03-08T20:21:28.788Z]
[task 2019-03-08T20:21:28.788Z] 2. If ESLint is installed locally, then it's likely that the plugin isn't installed correctly. Try reinstalling by running the following:
[task 2019-03-08T20:21:28.789Z]
[task 2019-03-08T20:21:28.789Z] npm i eslint-plugin-no-unsanitized@latest --save-dev
[task 2019-03-08T20:21:28.789Z]
[task 2019-03-08T20:21:28.789Z] Path to ESLint package: /builds/worker/checkouts/gecko/devtools/client/debugger/new/node_modules/eslint
[task 2019-03-08T20:21:28.789Z]
[task 2019-03-08T20:21:28.789Z] If you still can't figure out the problem, please stop by https://gitter.im/eslint/eslint to chat with the team.
[task 2019-03-08T20:21:28.789Z]
[task 2019-03-08T20:21:28.855Z] error Command failed with exit code 2.
[task 2019-03-08T20:21:28.855Z] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[task 2019-03-08T20:21:28.911Z] error Command failed with signal "SIGTERM".
[task 2019-03-08T20:21:28.911Z] error Command failed with signal "SIGTERM".
[task 2019-03-08T20:21:28.911Z] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[task 2019-03-08T20:21:28.911Z] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[task 2019-03-08T20:21:28.921Z] error Command failed with signal "SIGTERM".
[task 2019-03-08T20:21:28.921Z] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[task 2019-03-08T20:21:29.278Z] ERROR: "lint:js" exited with 1.
[task 2019-03-08T20:21:29.283Z] error Command failed with exit code 1.
[task 2019-03-08T20:21:29.283Z] info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
[taskcluster 2019-03-08 20:21:29.936Z] === Task Finished ===
[taskcluster 2019-03-08 20:21:29.936Z] Unsuccessful task run with exit code: 1 completed in 713.376 seconds

Flags: needinfo?(jlaster)
Assignee

Comment 4

3 months ago

sorry about that.

Flags: needinfo?(jlaster)

Comment 5

2 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/423f48c98230
Lint Debugger on try. r=davidwalsh
Flags: needinfo?(ahal)

Hm, I can't reproduce this locally. This is probably the tests fault rather than the change. Maybe we should disable the test while I try to figure this out.

I'll run a few try pushes to see if I can reproduce.

Flags: needinfo?(ahal)

I think the test is intermittent (if you look at jlast's push there were two passes and two failures) and is likely unrelated to his changes. This test only runs when specific files are modified, which might explain why this failure hasn't shown up before.

I'm looking into why it's intermittent now. Obviously a 50% pass rate isn't acceptable so I'm fine if we disable the test in the meantime.

I'll track fixing this test in bug 1534375.

Comment 10

2 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68834c8b15bd
Lint Debugger on try. r=davidwalsh

I've confirmed that this test fails on vanilla mozilla-central as well, so please don't backout the above push if it happens again. I think I have a handle on the problem over in bug 1534375.

Comment 13

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Assignee: nobody → jlaster
Assignee

Updated

2 months ago
Flags: needinfo?(jlaster)
You need to log in before you can comment on or make changes to this bug.