Closed Bug 1534552 Opened 7 months ago Closed 4 months ago

Properly document selection resetting in UrlbarInput::_loadURL

Categories

(Firefox :: Address Bar, task, P3)

task

Tracking

()

RESOLVED FIXED
Firefox 69
Tracking Status
firefox68 --- fixed
firefox69 --- fixed

People

(Reporter: dao, Assigned: okonaraddi)

References

Details

Attachments

(1 file)

In bug 1533691, mak said that this code would be "necessary for spoof protection, so that the domain stays visible." The code comment however says: "Ensure the start of the URL is visible for usability reasons."
This is vague enough to be useless if not actively misleading.

Yeah, it's actually both usability and spoof prevention, the host is an important information that should stay visible as far as possible.

Priority: -- → P5

Gonna up the priority because P5 is almost wontfix and the current documentation is just not good. Also marking Task. (By definition tasks have low user impact, and making all tasks P5s seems a bit silly.)

Type: enhancement → task
Priority: P5 → P3
Assignee: nobody → okonaraddi
Status: NEW → ASSIGNED
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/611f5c630114
Properly document selection resetting in UrlbarInput::_loadURL r=adw

Comment on attachment 9069791 [details]
Bug 1534552 - Properly document selection resetting in UrlbarInput::_loadURL r=adw!

Beta/Release Uplift Approval Request

  • User impact if declined: No user impact, could potentially avoid conflicts with future quantumbar uplifts
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Only fixing up a comment
  • String changes made/needed:
Attachment #9069791 - Flags: approval-mozilla-beta?
Flags: qe-verify-
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

Comment on attachment 9069791 [details]
Bug 1534552 - Properly document selection resetting in UrlbarInput::_loadURL r=adw!

updating a comment, effectively a no-op, approved for 68.0b8

Attachment #9069791 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.