Closed Bug 1535257 Opened 1 year ago Closed 1 month ago

0.32 - 0.42% installer size (linux32, linux64, osx-cross, windows2012-32, windows2012-64) regression on push e913585fdb4bdd73946b5e357c78da7221a71a53 (Thu Mar 14 2019)

Categories

(Firefox :: Messaging System, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fix-optional

People

(Reporter: igoldan, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs, Regression)

Details

(Keywords: backlog-deferred, perf-alert, regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=e913585fdb4bdd73946b5e357c78da7221a71a53

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

300KBytes installer size linux64 pgo 69,616,919.58 -> 69,906,754.42
200KBytes installer size windows2012-32 pgo 67,036,780.50 -> 67,294,900.08
200KBytes installer size windows2012-64 pgo 69,725,203.25 -> 69,984,312.42
200KBytes installer size linux32 pgo 69,706,460.67 -> 69,952,071.83
200KBytes installer size osx-cross opt 76,423,131.25 -> 76,668,593.92

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=19909

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Component: General → Activity Streams: Newtab
Product: Testing → Firefox
Flags: needinfo?(rrosario)
Flags: needinfo?(rrosario)
See Also: → 1533662

You could use this bug also for logging optimization efforts. But if you file a separate bug for that, please link it against this one.

Priority: -- → P3
Blocks: cfr
No longer blocks: pinned-tabs-68
Component: Activity Streams: Newtab → Messaging System

Clearing up regression bugs that have since shipped to users. It looks like there are some potential optimisation efforts in bug 1534996, but I don't think it makes sense to keep this bug open.

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.