Closed Bug 1533662 Opened 3 years ago Closed 1 year ago

0.44 - 0.48% installer size (linux64, osx-cross, windows2012-32, windows2012-64) regression on push 6a3b22130b996d2ea931525093f3e6103ed13d20 (Thu Mar 7 2019)

Categories

(Firefox :: Messaging System, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- fix-optional

People

(Reporter: igoldan, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug, Regression)

Details

(Keywords: backlog-deferred, perf-alert, regression)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=6a3b22130b996d2ea931525093f3e6103ed13d20

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

200KBytes installer size windows2012-64 pgo 69,195,671.75 -> 69,530,167.83
200KBytes installer size windows2012-32 pgo 66,570,287.75 -> 66,886,088.58
300KBytes installer size linux64 pgo 69,183,432.83 -> 69,509,191.25
200KBytes installer size osx-cross opt 75,907,061.08 -> 76,240,828.08

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=19808

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Component: General → Activity Streams: Newtab
Product: Testing → Firefox
Flags: needinfo?(rrosario)

These are animations that design has indicated as critical for the user experience of one of our new features (see https://mozilla.invisionapp.com/share/R3OVTEX9X76#/screens).

We can file an issue to look into optimizing them further, would that be acceptable?

(In reply to Kate Hudson :k88hudson from comment #1)

These are animations that design has indicated as critical for the user experience of one of our new features (see https://mozilla.invisionapp.com/share/R3OVTEX9X76#/screens).

We can file an issue to look into optimizing them further, would that be acceptable?

Sure thing.

See Also: → 1535257

Ricky, could you set a priority for the optimization task on this bug directly?

Depends on: 1534996
Flags: needinfo?(rrosario)
Priority: -- → P3
Blocks: cfr
No longer blocks: pinned-tabs-68
Component: Activity Streams: Newtab → Messaging System

Clearing up regression bugs that have since shipped to users. It looks like there are some potential optimisation efforts in bug 1534996, but I don't think it makes sense to keep this bug open.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.