Crash in [@ libwayland-client.so.0.3.0@0xa8e0]

RESOLVED DUPLICATE of bug 1517205

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1517205
2 months ago
a month ago

People

(Reporter: pascalc, Unassigned)

Tracking

(Blocks 1 bug, {crash})

67 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 wontfix, firefox67 wontfix, firefox68 affected)

Details

(crash signature)

(Reporter)

Description

2 months ago

This bug is for crash report bp-9e6250f8-4e0a-4833-82c6-227b90190315.

Top 10 frames of crashing thread:

0 libwayland-client.so.0.3.0 libwayland-client.so.0.3.0@0xa8e0 
1 libwayland-client.so.0.3.0 libwayland-client.so.0.3.0@0x78b8 
2 libwayland-client.so.0.3.0 libwayland-client.so.0.3.0@0xbb71 
3 libwayland-client.so.0.3.0 libwayland-client.so.0.3.0@0x7dfb 
4 libEGL_mesa.so.0.0.0 libEGL_mesa.so.0.0.0@0x23cb3 
5 libEGL_mesa.so.0.0.0 libEGL_mesa.so.0.0.0@0x1140d 
6 libxul.so mozilla::gl::GLContextEGL::SwapBuffers gfx/gl/GLLibraryEGL.h:226
7 libxul.so mozilla::layers::CompositorOGL::EndFrame gfx/layers/opengl/CompositorOGL.cpp:1746
8 libxul.so non-virtual thunk to mozilla::layers::ContainerLayerComposite::Cleanup gfx/layers/composite/ContainerLayerComposite.cpp:711
9 libxul.so mozilla::layers::LayerManagerComposite::EndTransaction gfx/layers/composite/LayerManagerComposite.cpp:970

(Reporter)

Updated

2 months ago
(Reporter)

Comment 1

2 months ago

Marking as wontfix for 67 as Wayland support won't ship in that release and the amount of crashes is extremely low.

I found another signature with the same stack.

Crash Signature: [@ libwayland-client.so.0.3.0@0xa8e0] → [@ libwayland-client.so.0.3.0@0xa8e0] [@ libwayland-client.so.0.3.0@0x9910]
Crash Signature: [@ libwayland-client.so.0.3.0@0xa8e0] [@ libwayland-client.so.0.3.0@0x9910] → [@ libwayland-client.so.0.3.0@0x9910] [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.so.0.3.0@0xa8e0]
Crash Signature: [@ libwayland-client.so.0.3.0@0x9910] [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.so.0.3.0@0xa8e0] → [@ libwayland-client.so.0.3.0@0x9910] [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.…

Removed an unrelated signature and added a new one.

Crash Signature: [@ libwayland-client.so.0.3.0@0x9910] [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.… → [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.…

I took the 2 most prominent libwayland-client.so signatures, looked at the systems they were happening on, and tried to find the corresponding library. On was on Arch and the other on Ubuntu. I proceeded with reprocessing one of each, and they both point to wl_list_insert. New crash reports using the same version of the library will now be symbolicated, and I'm trying to get older ones to be reprocessed as well.

Crash Signature: [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.… → [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.…

BTW, one of them was pointing to bug 1538125, so they are in fact likely to be the same underlying problem.

Let's be a little more specific.

Crash Signature: [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.… → [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.…

Somehow the link doesn't work if I add the calling frame...

Crash Signature: [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.… → [@ libwayland-client.so.0.3.0@0x9923] [@ libwayland-client.so.0.3.0@0x9a70] [@ libwayland-client.so.0.3.0@0x9ec4] [@ libwayland-client.so.0.3.0@0x9ecf] [@ libwayland-client.so.0.3.0@0x9f04] [@ libwayland-client.so.0.3.0@0xa10f] [@ libwayland-client.…

(In reply to Mike Hommey [:glandium] from comment #5)

BTW, one of them was pointing to bug 1538125, so they are in fact likely to be the same underlying problem.

That was me accidentally putting it in the signature, but it's a different stack. On the other hand it's likely that bug 1538125 and bug 1517205 are the same issue.

The wl_list_insert() crash is Bug 1517205 as we inserted to already released list.

Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1517205
You need to log in before you can comment on or make changes to this bug.