Closed Bug 1535568 Opened 2 years ago Closed 10 months ago

[Wayland][resistFingerprinting] First maximized window dimensions are not being rounded down on startup

Categories

(Core :: Widget: Gtk, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

STR:

  1. Start with GDK_BACKEND=wayland on Ubuntu 18.10.
  2. Set privacy.resistFingerprinting = true.
  3. Maximize window.
  4. Restart firefox.

Window should be non-maximized and reduced in size like with XWayland due to resist fingerprinting rounding down window dimensions but instead it remains full size (but not maximized). Only the first window is affected, other maximized windows in the session get rounded correctly.

How do you restart the browser? Just quit + start gives me non-maximized browser on Fedora 30 / latest nightly. Thanks.

Flags: needinfo?(ke5trel)

Try it with two maximized windows in the session, after quitting with Ctrl+Q and resuming the previous session, both windows should be the exact same size but with Wayland backend the first window is the wrong size.

Flags: needinfo?(ke5trel)
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1525762
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Regressed by: 1540856
Resolution: WORKSFORME → ---

Presumably this has something to do with the early blank window paint code. Bug 1540856 just fixed a regression that briefly disabled that code. It didn't cause this.

No longer depends on: 1525762
No longer regressed by: 1540856
Regressed by: 1336227
See Also: → 1448423, 1535565

(In reply to Kris Maglione [:kmag] from comment #5)

Presumably this has something to do with the early blank window paint code.

Yes, it does not happen with browser.startup.blankWindow = false.

I cannot reproduce this since upgrading to Ubuntu 19.10 with Nightly builds after the regression, it appears to have been fixed upstream.

Status: REOPENED → RESOLVED
Closed: 2 years ago10 months ago
Resolution: --- → WORKSFORME
Keywords: regression
You need to log in before you can comment on or make changes to this bug.