Intermittent video glitches on AppRTC calls

VERIFIED FIXED

Status

()

defect
P2
normal
Rank:
15
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: dminor, Assigned: dminor)

Tracking

(Blocks 1 bug, {regression})

67 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 wontfix, firefox67+ verified, firefox68 verified)

Details

()

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1315283 +++

[Steps to reproduce]:

  1. Launch Firefox on 2 separate stations
  2. Go to https://apprtc.appspot.com/ on both stations and initiate a call (enter a room)
  3. Wait a few minutes and pay attention to the video playback

[Expected result]:

  • The call is properly taking place, no video or audio issues are encountered

[Actual result]:

  • Video glitches occur at the bottom of the window mainly at the beginning of the call and sometimes they keep emerge until the end of the call (see the attached screenshot https://goo.gl/VE9DHi)

Looks like the fix from Bug 1315283 was accidentally dropped as part of the branch 64 update in Bug 1376873.

Blocks: 1376873
Rank: 15

[Tracking Requested - why for this release]:

Dan, once landed in nightly, is the patch safe for uplift to 67 beta?

Flags: needinfo?(dminor)

(In reply to Neha Kochar [:neha] from comment #3)

[Tracking Requested - why for this release]:

Dan, once landed in nightly, is the patch safe for uplift to 67 beta?

Yes, this should be very safe, it is just restoring code that was accidentally removed.

Flags: needinfo?(dminor)

Tracking for 67 as we will take an uplift, thanks!

See Also: → 1536048

Marking leave-open until the fix is upstreamed.

Status: NEW → ASSIGNED
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0898f9cfe092
Restore UpdateCodecFrameSize to vp9_impl.cc; r=bwc

Comment on attachment 9051357 [details]
Bug 1535584 - Restore UpdateCodecFrameSize to vp9_impl.cc; r=ng!

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1376873
  • User impact if declined: Rendering glitches when the resolution changes while using vp9 codec.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See Comment 1.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is low risk as it is just restoring code that was accidentally removed during the webrtc.org branch 64 update.
  • String changes made/needed: None
Attachment #9051357 - Flags: approval-mozilla-beta?
Flags: qe-verify?
Flags: qe-verify? → qe-verify+

FYI, since we have STR, I would like the fix to be verified on Nightly before approving the uplift to Beta.

QA Whiteboard: [qa-triaged]

This issue could not be reproduced anymore on Nightly v68.0a1 wit the patch from comment 8. I will mark firefox68 as Verified. Leaving the qa-verify+ flag for latter uplift verification. Thank you!

Comment on attachment 9051357 [details]
Bug 1535584 - Restore UpdateCodecFrameSize to vp9_impl.cc; r=ng!

Fix for a P2 WebRTC visual regression since 64, verified on Nightly, uplift approved for 67 Beta 5, thanks!

Attachment #9051357 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(daniel.bodea)
Duplicate of this bug: 1536048

Filed upstream issue here: https://bugs.chromium.org/p/webrtc/issues/detail?id=10476. Marking as fixed as we can track upstreaming this through that issue.

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Keywords: leave-open
Resolution: --- → FIXED

I verified this bug fix on the latest nightly (Build ID 20190325095153), Fx beta 67.0b5 (Build ID 20190325115716)by making a video call between MacOS, Linux and Windows 10 for around 10 minutes. I didn't observe any video glitches during this call.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(daniel.bodea)
QA Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.