Closed Bug 1536522 Opened 6 months ago Closed 6 months ago

Fennec x86-64 beta doesn't have the right package name

Categories

(Release Engineering :: General, defect, P1, blocker)

Unspecified
Android
defect

Tracking

(firefox-esr60 unaffected, firefox66 unaffected, firefox67+ verified, firefox68 verified)

VERIFIED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 + verified
firefox68 --- verified

People

(Reporter: mtabara, Assigned: jlorenzo)

References

Details

Attachments

(2 files)

    package_names_check.validate(apks_metadata_per_paths)
  File "/builds/scriptworker/lib/python3.6/site-packages/mozapkpublisher/common/apk/checker.py", line 26, in validate
    raise BadSetOfApks('Expected product types {}, found {}'.format(self.expected_product_types, types))
mozapkpublisher.common.exceptions.BadSetOfApks: Expected product types ['org.mozilla.firefox_beta'], found {'org.mozilla.firefox_beta', 'org.mozilla.fennec_aurora'}
exit code: 1

From here via this task

Last Fennec beta we shipped was 66.0b13 with this pushapk task

At first glance, sounds like we have an additional dependency "build-signing-android-x86_64-nightly/opt" which we didn't have before.

After more consideration, turns out that x86-64 thing is expected after all because of bug 1505538.
Most likely there's some inner build in-config that we may have forgotten to switch for beta x86-64. So far it rode the nigtly train successfully but when it merged to beta, it still defaulted to:

attribute: package='b'org.mozilla.fennec_aurora'' for /builds/scriptworker/work/cot/LZB2QnESRNCGOImU3cHLWw/public/build/target.apk"

See Also: → Fennec-x86_64

The error reported by PushApk is a valid one. The x86-64 APK is busted[1]. Its package name is org.mozilla.fennec_aurora instead of org.mozilla.firefox_beta.

I manually pushed the sane APKs to Google Play. However, we will hit that problem again, next week. We need to fix the package name. Moving the bug to Build System because the root cause comes from the build task.

[1] https://queue.taskcluster.net/v1/task/LZB2QnESRNCGOImU3cHLWw/runs/0/artifacts/public/build/target.apk

Severity: normal → blocker
Component: Release Automation: Pushapk → Task Configuration
Priority: -- → P1
Product: Release Engineering → Firefox Build System
QA Contact: jlorenzo
Summary: 67.0b3 Fennec pushapk failed for BadSetOfApks → Fennec x86-64 beta doesn't have the right package name

(In reply to Johan Lorenzo [:jlorenzo] from comment #3)

The error reported by PushApk is a valid one. The x86-64 APK is busted[1]. Its package name is org.mozilla.fennec_aurora instead of org.mozilla.firefox_beta.

How is this happening? Trunk/Nightly is producing org.mozilla.fennec_aurora just fine: aapt dump badging on https://queue.taskcluster.net/v1/task/dUUD4muTS1Cwu9YVpEhqNQ/runs/0/artifacts/public/build/target.apk yields

package: name='org.mozilla.fennec_aurora' versionCode='2015617951' versionName='68.0a1'

That suggests that one of the uplift/branch rewriting scripts isn't handling x86_64 -- but I can't figure out which one. All the other configure.sh is ABI-agnostic to the best of my knowledge.

Assignee: nobody → jlorenzo
Component: Task Configuration → General
Product: Firefox Build System → Release Engineering
QA Contact: catlee

Make Android mozconfig use the beta branding

Let mergeday scripts handle missing Android mozconfigs

Depends on D24340

Comment on attachment 9052537 [details]
Bug 1536522 - Make Android mozconfig use the beta branding r=nalexander

r+'d by nalexander on Phabricator.
Landed on beta at https://hg.mozilla.org/releases/mozilla-beta/rev/d199f4768de56941b633c1bdce7cba703b02274d. We don't want this patch on any other branch

Attachment #9052537 - Flags: review+
Attachment #9052537 - Flags: checked-in+
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a19986b12bd6
Let mergeday scripts handle missing Android mozconfigs r=aki,nalexander
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Blocks: 1540152

I've confirmed that Fennec x86_64 is live in Fennec 68 Nightly and 67 Beta on the Google Play Store. And we're receiving some x86_64 crash reports from Fennec 67 Beta users.

Status: RESOLVED → VERIFIED
OS: Unspecified → Android
You need to log in before you can comment on or make changes to this bug.