Closed Bug 1536776 Opened 5 years ago Closed 5 years ago

quantumbar doesn't decode percent-encoded urls

Categories

(Firefox :: Address Bar, defect, P2)

68 Branch
defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox68 --- verified

People

(Reporter: lilydjwg, Assigned: standard8)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

Actual results:

The URL is shown as https://zh.wikipedia.org/wiki/Wikipedia:%E9%A6%96%E9%A1%B5

Expected results:

The URL should be shown as https://zh.wikipedia.org/wiki/Wikipedia:首页 (which is the case without quantumbar).

I'm using latest nightly on Arch Linux.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0
20190320112939

Blocks: quantumbar
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Untriaged → Address Bar
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All

Thanks, it looks like we are missing a test for this.

Priority: -- → P2
Assignee: nobody → standard8
Status: NEW → ASSIGNED
No longer blocks: quantumbar
Blocks: 1538771
Blocks: 1538773
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8df98cd46907
Fix display of percent-encoded URLs in QuantumBar. r=adw
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Points: --- → 3
Flags: qe-verify+
QA Contact: aflorinescu

I could not reproduce this issue on my Ubuntu device.
lilydjwg, can you help us confirm the fix?
Thank you!

Flags: needinfo?(lilydjwg)

Yes it's fixed.

Status: RESOLVED → VERIFIED
Flags: needinfo?(lilydjwg)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: