Open Bug 153750 Opened 20 years ago Updated 12 years ago

Provide access to alternate style sheets

Categories

(Camino Graveyard :: Accessibility, enhancement, P3)

All
macOS
enhancement

Tracking

(Not tracked)

ASSIGNED

People

(Reporter: bugmail, Assigned: bugzilla-graveyard)

References

(Blocks 1 open bug, )

Details

(Keywords: access)

At present, there is no way to access alternate style sheets in Chimera. A
mechanism should be provided to select such style sheets similar to Mozilla's
View/Use Style menu.
Blocks: 153699
ua sytle sheet pref RFE
Assignee: saari → pinkerton
Summary: Provide access to alternate style sheets → [RFE] Provide access to alternate style sheets
nope.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
actually, this was brought during a recent meeting as being a useful
accessibility  feature. so, reopening.
Status: RESOLVED → REOPENED
Component: General → Accessibility
Resolution: WONTFIX → ---
bryner, feel free to reassign. :)

also, if there's an earlier bug on this, feel free to dup this. i couldn't find
one after a quick search...
Assignee: pinkerton → bryner
Severity: normal → enhancement
Status: REOPENED → NEW
I'll take this.
Assignee: bryner → sfraser
Summary: [RFE] Provide access to alternate style sheets → Provide access to alternate style sheets
so, are we ever going to get this feature in camino?
it would be nice to have.
*** Bug 249991 has been marked as a duplicate of this bug. ***
Perhaps this could be implemented as a popup menu on the status bar, as for the
popup blocker.
Priority: -- → P3
Target Milestone: --- → Camino1.2
(In reply to comment #8)
> Perhaps this could be implemented as a popup menu on the status bar, as for the
> popup blocker.

This is something that should really go in the View menu, because people want to
be able to hide the status bar.  It's fine for it to *also* go in the status bar
(and IMHO is more discoverable that way), but access to the stylesheets should
primarily be somewhere that can't be hidden so that we can be compliant with
CSS2: http://www.w3.org/TR/REC-CSS2/conform.html#conformance (point 5)

Firefox also has an option in its menu to display the page without styles.
I am also in favor of both.
QA Contact: winnie → accessibility
Blocks: altss
*** Bug 353603 has been marked as a duplicate of this bug. ***
Too bad we only have 5 votes for Camino! :(
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
Target Milestone: Camino1.6 → ---
Assignee: sfraser_bugs → nobody
http://tantek.com/CSS/Examples/codeisfreespeech.html

provides a nice testcase (view in Fx 3 to see how they work it).

http://mxr.mozilla.org/seamonkey/source/browser/base/content/browser.js#5161

is how Firefox implements this.

I may be able to take a look at this next week.
Assignee: nobody → cl-bugs-new
Hardware: Macintosh → All
A couple more notes-to-self from talking with gavin on IRC:

* the menu calls |stylesheetSwitchAll()|, which loops through and disables everything other than the newly selected stylesheet
* it then calls |setStyleDisabled(false)| to enable the currently selected stylesheet
Status: NEW → ASSIGNED
You need to log in before you can comment on or make changes to this bug.