Closed Bug 1537667 Opened 5 years ago Closed 5 years ago

allow the 'layout.display-list.retain' pref to work on android

Categories

(Core :: Web Painting, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.

Fennec isn't e10s, so neither existing check worked.

Wrong pref name (for bug summary and commit message)?

Summary: allow the 'layout.display-list.dump' pref to work on android → allow the 'layout.display-list.retain' pref to work on android

(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)

Wrong pref name (for bug summary and commit message)?

Ooops, copy paste fail. I'll fix. Thanks.

Attachment #9052497 - Attachment is obsolete: true
Pushed by tnikkel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4f607065a97f
Allow the 'layout.display-list.retain' pref to work on android. r=mattwoodrow
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Should the value be set to true in about:config?

(In reply to csheany from comment #7)

Should the value be set to true in about:config?

No. This bug is just allowing the pref to actually work on android. Before this patch flipping the pref had no effect.

Thank you for your response.

Is there a bug to follow for when it will be enabled on Nightly?

Is Bug 1413567 about release?

Does it require restarting?

Is this a relevant article (https://hacks.mozilla.org/2018/06/retained-display-lists)?

(In reply to csheany from comment #9)

Is there a bug to follow for when it will be enabled on Nightly?
Is Bug 1413567 about release?

I'll either use that bug or a bug that depends on that bug.

Does it require restarting?

It looks like it's a live pref, but I would restart just to be sure.

Is this a relevant article
(https://hacks.mozilla.org/2018/06/retained-display-lists)?

Yes, that enabled for android.

Regressions: 1538705

This is in the 68.0beta android release notes as "Improved web page painting performance by avoiding redundant calculations during paint".

(In reply to Julien Cristau [:jcristau] from comment #13)

This is in the 68.0beta android release notes as "Improved web page painting
performance by avoiding redundant calculations during paint".

Not sure if it matters, but the proper bug is bug 1413567.

This bug only made it so that the pref had an effect if you flipped it on android. We actually flipped the pref in bug 1413567.

Flags: needinfo?(jcristau)

Thanks. (It's not a big deal, the bug association is not visible on the website, but I'll move this.)

Flags: needinfo?(jcristau)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: