Closed Bug 1538047 Opened 2 years ago Closed 2 years ago

Plain text attachment cut off due to wrong charset detection (UTF-8 as Windows-1252)

Categories

(bugzilla.mozilla.org :: General, defect)

Staging
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: botond, Assigned: kohei.yoshino)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review

STR:

Navigate to this attachment (as linked from this comment).

The attachment is a text/plain attachment containing the complete source of an HTML file.

Expected results:

The HTML source is rendered in full as plain text.

Actual results:

The HTML source is cut off part way, e.g. for me the last thing I see is:

    <div class="content-box content-box-

Reloading the page causes it to either load completely, or be cut off at a different place. (If the page loads completely on the first try, reloading will usually cause it to be cut off on a subsequent load.)

Can reproduce the issue. Sometimes a blank page is returned 🤔

I can reproduce it locally as well. This is because the file is served as text/plain; charset=windows-1252 instead of text/plain; charset=UTF-8 due to wrong charset detection. In Chrome, you’ll get ERR_INCOMPLETE_CHUNKED_ENCODING intermittently.

Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Summary: Plain text attachment cut off → Plain text attachment cut off due to wrong charset detection (UTF-8 as Windows-1252)
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1546698
You need to log in before you can comment on or make changes to this bug.