Closed Bug 1538126 Opened 6 months ago Closed 6 months ago

Bugs in Office 365' Word without legacy keyCode and charCode

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(firefox-esr60 unaffected, firefox66- fix-optional, firefox67 fix-optional, firefox68 fix-optional)

RESOLVED DUPLICATE of bug 1538652
Tracking Status
firefox-esr60 --- unaffected
firefox66 - fix-optional
firefox67 --- fix-optional
firefox68 --- fix-optional

People

(Reporter: denschub, Unassigned)

References

Details

(Keywords: regression, site-compat)

As part of the QA efforts in bug 1536453 around PowerPoint, QA has found two issues with Word that are related:

  • CMD+A selects the text but shifts the focus out of the word_document, user cannot add extra text after this form of selection
  • After a text is added double clicking on it and writing something else doesn't replace the string but instead adds the new text to the existing one(happens with a flicker)

They could be fixed by adding word-edit.officeapps.live.com to the dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode pref.

Filing a separate issue here so we can track those independent from thee PowerPoint issue, which has been addressed by a Normandy rollout, and the matching pref-patch is already in Nightly.

I am not sure if we should be tracking these issues for 66. While they are a regression, they do not completely break the application, unlike the PowerPoint issue. We could also decide not to use the pref to hotfix those cases, and wait for Microsoft to respond.

Priority: -- → P3

Has these issues been reported to Microsoft? Since these are web page issues, not implementation issues.

Flags: needinfo?(dschubert)
Priority: P3 → --
Component: DOM: Events → Desktop
Product: Core → Web Compatibility
Version: 66 Branch → unspecified

Has these issues been reported to Microsoft?

We have a thread about the issues in bug 1536453, which have the same cause (bug 1502795 reaching Release). The Word issues were not known initially, but I just added them to the thread. :)

Flags: needinfo?(dschubert)

QA has filed bug 1538652 and bug 1538651 with more details. Let's mark this one as a dupe.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1538652
You need to log in before you can comment on or make changes to this bug.