Closed Bug 1538652 Opened 6 months ago Closed 6 months ago

Selecting strings in Office's365 Word documents in any way shifts the focus out of the document

Categories

(Core :: DOM: Events, defect, P1)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 + fixed
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: vlucaci, Assigned: denschub)

References

(Regression)

Details

(Keywords: regression)

Affected versions

  • 68.0a1 (2019-03-24)
  • 67.0b4
  • 66.0.1

Affected platforms

  • Windows 10x64
  • macOS 10.14
  • Ubuntu 16.04

Steps to reproduce

  1. Launch FF.
  2. Go to Office365 login page.
  3. Login with valid credentials.
  4. Select a new blank word document.
  5. Input any random string in the document.
  6. Double click the string or ctrl+a to select it all.

Expected result

  • Selecting the string via double click or CTRL+A does not shift the focus out of the word_document.

Actual result

  • Selecting the string via double click or CTRL+A shifts the focus out of the word_document, user cannot add extra text after this form of selection

Regression range

  • N/A since the fix for this issue is already known.

Additional notes

  • Issue was submitted as per discussed in Slack group #thepowerrrrpoint and we have concluded that this issue is solved if changing the value of dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode pref to *.officeapps.live.com
Priority: -- → P1
Duplicate of this bug: 1538126
Blocks: 1502795
Keywords: regression
See Also: → 1536453

This is fixed via bug 1538966.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Assignee: nobody → dschubert
No longer blocks: 1502795
Regressed by: 1502795
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.