Android arm builds busted with rust >= 1.33 after bug 1521734

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

[task 2019-03-23T01:45:46.500Z] 01:45:46     INFO -     Compiling target-lexicon v0.2.0
[task 2019-03-23T01:45:46.500Z] 01:45:46     INFO -       Running `/builds/worker/workspace/build/src/obj-firefox/release/build/target-lexicon-42376ff18ae281f1/build-script-build`
[task 2019-03-23T01:45:46.500Z] 01:45:46     INFO -  [target-lexicon 0.2.0] thread 'main' panicked at 'can't find custom target thumbv7neon-linux-androideabi', /builds/worker/workspace/build/src/third_party/rust/target-lexicon/build.rs:99:5

Filed upstream at https://github.com/CraneStation/target-lexicon/issues/7

IS there anyway to get local builds to work with a simple workaround type patch to use a supported target while waiting for resolution?./third_party/rust/target-lexicon/src/targets.rs

Duplicate of this bug: 1538135

(In reply to mac198442 from comment #1)

IS there anyway to get local builds to work with a simple workaround type patch to use a supported target while waiting for resolution?./third_party/rust/target-lexicon/src/targets.rs

Use rust 1.32.

Assignee: nobody → mh+mozilla

(In reply to Mike Hommey [:glandium] from comment #4)

(In reply to mac198442 from comment #1)

IS there anyway to get local builds to work with a simple workaround type patch to use a supported target while waiting for resolution?./third_party/rust/target-lexicon/src/targets.rs

Use rust 1.32.

If that is you best answer, then my feeling is that bug 1521734 needs to be backed out until it works with the latest stable version of rustc.

You can also use the patch attached to this bug, or build with --without-thumb.

(In reply to Mike Hommey [:glandium] from comment #6)

You can also use the patch attached to this bug, or build with
--without-thumb.

Thanks "ac_add_options --without-thumb" worked for me.

I will wait for a properly reviewed path to land before removing this from my .mozconfig.

Backed out changeset c0399366d123 (Bug 1538419) for cargo library build bustages CLOSED TREE

Failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&fromchange=f5dd833c3b60b3365d2c49d930748e33a22651b6&selectedJob=236013274

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=236013274&repo=autoland&lineNumber=6102

02:58:19 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang-cl.exe -Xclang -std=gnu99 --target=aarch64-windows-msvc -Fozutil.obj -c -DDEBUG=1 -Iz:/build/build/src/modules/zlib/src -Iz:/build/build/src/obj-firefox/modules/zlib/src -Iz:/build/build/src/obj-firefox/dist/include -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/nss -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -fcrash-diagnostics-dir=z:/build/public/build -nologo -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -Gw -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Z7 -fno-limit-debug-info -O2 -Xclang -mdisable-fp-elim -WX -Qunused-arguments -Xclang -MP -Xclang -dependency-file -Xclang .deps/zutil.obj.pp -Xclang -MT -Xclang zutil.obj z:/build/build/src/modules/zlib/src/zutil.c
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/modules/zlib/src'
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/js/src'
02:58:19 INFO - js/src/ProfilingStack.obj
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/js/src'
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/memory/volatile'
02:58:19 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang-cl.exe --target=aarch64-windows-msvc -FoUnified_cpp_memory_volatile0.obj -c -Iz:/build/build/src/obj-firefox/dist/stl_wrappers -DDEBUG=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -Iz:/build/build/src/memory/volatile -Iz:/build/build/src/obj-firefox/memory/volatile -Iz:/build/build/src/obj-firefox/dist/include -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/nss -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -Qunused-arguments -fcrash-diagnostics-dir=z:/build/public/build -TP -nologo -Zc:sizedDealloc- -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -Gw -Wno-inline-new-delete -Wno-invalid-offsetof -Wno-microsoft-enum-value -Wno-microsoft-include -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Wno-inconsistent-missing-override -Wno-implicit-exception-spec-mismatch -Wno-unused-local-typedef -Wno-ignored-attributes -Wno-used-but-marked-unused -D_SILENCE_TR1_NAMESPACE_DEPRECATION_WARNING -GR- -Z7 -fno-limit-debug-info -O2 -Xclang -mdisable-fp-elim -WX -Xclang -MP -Xclang -dependency-file -Xclang .deps/Unified_cpp_memory_volatile0.obj.pp -Xclang -MT -Xclang Unified_cpp_memory_volatile0.obj z:/build/build/src/obj-firefox/memory/volatile/Unified_cpp_memory_volatile0.cpp
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/memory/volatile'
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/js/src/frontend'
02:58:19 INFO - js/src/frontend/Unified_cpp_js_src_frontend1.obj
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/js/src/frontend'
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/modules/fdlibm/src'
02:58:19 INFO - z:/build/build/src/sccache2/sccache.exe z:/build/build/src/clang/bin/clang-cl.exe --target=aarch64-windows-msvc -Fos_fabs.obj -c -Iz:/build/build/src/obj-firefox/dist/stl_wrappers -DDEBUG=1 -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -Iz:/build/build/src/modules/fdlibm/src -Iz:/build/build/src/obj-firefox/modules/fdlibm/src -Iz:/build/build/src/obj-firefox/dist/include -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/nss -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -Qunused-arguments -fcrash-diagnostics-dir=z:/build/public/build -TP -nologo -Zc:sizedDealloc- -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -Gw -Wno-inline-new-delete -Wno-invalid-offsetof -Wno-microsoft-enum-value -Wno-microsoft-include -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Wno-inconsistent-missing-override -Wno-implicit-exception-spec-mismatch -Wno-unused-local-typedef -Wno-ignored-attributes -Wno-used-but-marked-unused -D_SILENCE_TR1_NAMESPACE_DEPRECATION_WARNING -GR- -Z7 -fno-limit-debug-info -O2 -Xclang -mdisable-fp-elim -WX -Wno-sign-compare -wd4146 -wd4305 -wd4723 -wd4756 -Xclang -MP -Xclang -dependency-file -Xclang .deps/s_fabs.obj.pp -Xclang -MT -Xclang s_fabs.obj z:/build/build/src/modules/fdlibm/src/s_fabs.cpp
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/modules/fdlibm/src'
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/modules/fdlibm/src'
02:58:19 INFO - modules/fdlibm/src/s_floor.obj
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/modules/fdlibm/src'
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/js/src/rust'
02:58:19 INFO - js/src/rust/force-cargo-library-build
02:58:19 INFO - z:/build/build/src/rustc/bin/cargo.exe rustc --frozen --manifest-path z:/build/build/src/js/src/rust/Cargo.toml -vv --lib --target=aarch64-pc-windows-msvc --features 'cranelift_arm64' --
02:58:19 INFO - error: failed to calculate checksum of: Z:\build\build\src\third_party\rust\target-lexicon.rustfmt.toml
02:58:19 INFO - Caused by:
02:58:19 INFO - The system cannot find the file specified. (os error 2)
02:58:19 INFO - z:/build/build/src/config/makefiles/rust.mk:235: recipe for target 'force-cargo-library-build' failed
02:58:19 INFO - mozmake.EXE[4]: *** [force-cargo-library-build] Error 101
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/build/src/obj-firefox/js/src/rust'
02:58:19 INFO - z:/build/build/src/config/recurse.mk:74: recipe for target 'js/src/rust/target' failed
02:58:19 INFO - mozmake.EXE[3]: *** [js/src/rust/target] Error 2
02:58:19 INFO - mozmake.EXE[3]: *** Waiting for unfinished jobs....
02:58:19 INFO - mozmake.EXE[4]: Entering directory 'z:/build/build/src/obj-firefox/js/src/jit'
02:58:19 INFO - js/src/jit/Unified_cpp_js_src_jit3.obj
02:58:19 INFO - mozmake.EXE[4]: Leaving directory 'z:/build/buil

Flags: needinfo?(mh+mozilla)

I was expecting the version that was queued to fail to land with a conflict, but it didn't. The current version of the patch, updated after that was what I actually meant to land.

Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/c4304f249404
Add support for thumbv7neon to target-lexicon. r=froydnj
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Backout by rgurzau@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/67cc4d399e8a
Backed out changeset c0399366d123 for cargo library build bustages CLOSED TREE
You need to log in before you can comment on or make changes to this bug.