Filter Rules dialog appears truncated until manually resized

VERIFIED FIXED

Status

MailNews Core
Filters
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: robinf, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using June 23-08-1.0 build, using Windows 2000 professional:

Open Mail.
From Tools menu, choose Message Filters.
Click New.

By default, the Filter Rules dialog is truncated on the right side. You have to
manually resize it to display the complete dialog. Once Navin showed me I could
resize the dialog, I did so. Subsequently, the dialog remembers being resized,
even after I quit the app and restart. But this dialog shouldn't appear
truncated by default. Users may not know that they can manually resize the dialog.

Comment 1

16 years ago
This has been reported before, will find the report(s).  We actually have a few
dialogs on different platforms which behave this way, once resized all is okay.

Comment 2

16 years ago
*** Bug 147435 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

16 years ago
Created attachment 89013 [details] [diff] [review]
possible fix

Let us increase the width by 50 pixels and see what happens. Can I get reviews
? thx

Comment 4

16 years ago
Comment on attachment 89013 [details] [diff] [review]
possible fix

sr=bienvenu, ok, let's try it.
Attachment #89013 - Flags: superreview+

Comment 5

16 years ago
Comment on attachment 89013 [details] [diff] [review]
possible fix

r=cavin.
Attachment #89013 - Flags: review+
(Assignee)

Comment 6

16 years ago
fix checked in. Robin, can you create a new profile using tomorrow's trunk build
and see if this problem is fixed for you, thx.

Comment 7

16 years ago
Using june25 commercial trunk build with win98, looks ok to me.  Problem was via
prefill filters only, a new rules dialog from filter list was okay.  

Is there some reason this wasn't marked resolved?

Comment 8

16 years ago
Let me clarify -- for me in branch or previous trunk builds, on a new profile, a
new rules dialog arrived at via Message Filters was okay. However, the prefill
case was different and dialog was clipped on the right side.

Comment 9

16 years ago
Hmmm... I'm not sure what the difference is, but sometimes on new
(branch)profile I'm getting different results, clipped/not clipped.  In any
event, it looks okay in each try I've done with the trunk, via prefill or main
filter ui.
(Assignee)

Comment 10

16 years ago
marking fixed since it is fixed on trunk.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
Marking verified for trunk. If robinf sees it again she can reopen.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

16 years ago
Keywords: adt1.0.1, mozilla1.0.1, nsbeta1
(Reporter)

Comment 12

16 years ago
Using July-01-08-1.0.0 branch, using a new profile this appears to be fixed. I
tried accessing the dialog via "Create Filter from Message" context menu item as
well as Tools | Message Filters | New.

Comment 13

16 years ago
adding adt1.0.1-.  Let's get this in the next release.
Keywords: adt1.0.1 → adt1.0.1-
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.