Remove superfluous dot from use_legacy_keycode_and_charcode pref

RESOLVED FIXED in Firefox 66

Status

()

defect
--
major
RESOLVED FIXED
28 days ago
15 days ago

People

(Reporter: denschub, Assigned: denschub)

Tracking

66 Branch
mozilla68
Points:
---

Firefox Tracking Flags

(relnote-firefox 66+, firefox66blocking fixed, firefox67 fixed, firefox68 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

28 days ago

As reported here, there is a dot where it shouldn't be, which prevents *.officeapps-df.live.com to actually be fixed. Let's remove that dot.

(This may be the wrong component, but since the pref is DOM Event related, and the other bugs are filed here as well, it seemed fitting. Feel free to move.)

(Assignee)

Comment 2

28 days ago

[Tracking Requested - why for this release]:

This fixes the list of domains from bug 1538966, so this needs to be in the .3 dotrelease as well. Sorry.

Comment 3

28 days ago
Pushed by mitaylor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17a6bdaedd65
Remove superfluous dot from use_legacy_keycode_and_charcode pref. r=miketaylr

Comment 4

27 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 27 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
(Assignee)

Comment 5

27 days ago

Comment on attachment 9054011 [details]
Bug 1539618 - Remove superfluous dot from use_legacy_keycode_and_charcode pref. r=miketaylr

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1538966
  • User impact if declined: This fixes the domain list we added in bug 1538966, but added an additional point. If this doesn't get uplifted, *.officeapps-df.live.com will not be fixed.
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: Bug 1538970
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Amending an already shipped pref-only change
  • String changes made/needed:
Attachment #9054011 - Flags: approval-mozilla-release?
Attachment #9054011 - Flags: approval-mozilla-beta?

Comment on attachment 9054011 [details]
Bug 1539618 - Remove superfluous dot from use_legacy_keycode_and_charcode pref. r=miketaylr

Approved for 67 beta 7. I am leaving the approval for release as we don't know yet when we have it. Thanks.

Attachment #9054011 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Counting this as one of the drivers for 66.0.3.

Severity: normal → major

Comment on attachment 9054011 [details]
Bug 1539618 - Remove superfluous dot from use_legacy_keycode_and_charcode pref. r=miketaylr

OK for uplift for 66.0.3.
Dennis, is there a good way to verify this? I notice in bug 1538966 we did verify that fix.

Flags: needinfo?(dschubert)
Attachment #9054011 - Flags: approval-mozilla-release? → approval-mozilla-release+
Flags: qe-verify+
(Assignee)

Comment 10

21 days ago

Unfortunately, no. This change only affects office apps running at *.officeapps-df.live.com, and I actually don't know when they do, as I have never seen that domain. It was one of the domains Microsoft sent us, so we could probably ask them if we absolutely want to have a verification here, but at the moment, we can't verify this.

Flags: needinfo?(dschubert)
QA Whiteboard: [qa-triaged]

(In reply to Dennis Schubert [:denschub] from comment #10)

Unfortunately, no. This change only affects office apps running at *.officeapps-df.live.com, and I actually don't know when they do, as I have never seen that domain. It was one of the domains Microsoft sent us, so we could probably ask them if we absolutely want to have a verification here, but at the moment, we can't verify this.

Based on this I will remove the qe-verify+ flag since we can't actually test it.

Flags: qe-verify+

Noted for 66.0.3 as FIXED: Fix for keypress events in some Microsoft cloud applications

You need to log in before you can comment on or make changes to this bug.