Closed Bug 1538966 Opened 3 years ago Closed 3 years ago

Fix known sites fallout from mirroring charCode and keyCode values (1479964) in 66

Categories

(Core :: DOM: Events, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Root Cause Corner Case
Tracking Status
firefox66 blocking verified
firefox67 --- verified
firefox68 --- verified

People

(Reporter: miketaylr, Assigned: denschub, NeedInfo)

References

Details

Attachments

(2 files)

This bug covers the sites we want to add to the blacklist controlled by dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode.

We should get a patch landed ASAP, and request beta and release uplist to try to make the next dot release.

[Tracking Requested - why for this release]:

We want to get this patch into the next dot release.

Okay, here is a patch adding a few more domains to the prefs.

dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode:

  • For Office (bug 1538651, bug 1538652), we decided to add some wildcard domains. This is based on this comment, and initial conversations we had with Microsoft. It's probably the safest approach for us right now.
  • For IBM Webmail (bug 1538317), this patch only includes the one known domain. The domain is mentioned in IBMs docs, so it's likely a generic endpoint for one of their shared cloud offerings. We're working on getting more information here, but for now, that's all we have. Given we can't really tell what else is behind that domain, using a wildcard here would be dangerous. We can iterate in the future.

dom.keyboardevent.keypress.hack.dispatch_non_printable_keys:

  • For iCloud (bug 1537913), Adam confirmed in that bug that this resolves the issue. iCloud always seems to hard-redirect to the www-subdomain for these documents, so I see no reason to use a wildcard here.

Masayuki, could you have a look at that patch? We're trying to get this into the next dot-release, so you're a good first reviewer-try, given the timezone. :)

Flags: needinfo?(masayuki)

Thanks so much!

Keywords: checkin-needed

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/15a1ecb3c254
Use legacy keyCode and charCode for sites with known issues. r=masayuki

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Dennis, please request uplift to beta and release today for our next dot release, thanks!

Blocks: 1539087

Comment on attachment 9053591 [details]
Bug 1538966 - Beta/Release - Use legacy keyCode and charCode for sites with known issues. r=masayuki

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1502795
  • User impact if declined: Office 365's PowerPoint, Word, and OneNote (potentially others), as well as some iCloud functionality and IBM WebMail would be broken.
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's changing a pref value that's known to be working, as we previously have updated the value for Release.
  • String changes made/needed:
  • Do you want to request approval of these patches as well?:
Attachment #9053591 - Flags: approval-mozilla-release?
Attachment #9053591 - Flags: approval-mozilla-beta?

Note: Both patches here are basically the same - I only had to build a second one as the initial PowerPoint pref-value never got uplifted to Beta, so the patch wouldn't apply.

Also, as we decided to use a wildcard for Office, the just discovered bug 1539087 is already covered by this patch, without any changes.

Comment on attachment 9053591 [details]
Bug 1538966 - Beta/Release - Use legacy keyCode and charCode for sites with known issues. r=masayuki

Webcompat driver for 66.0.2, approved for release and beta branches, thanks!

Attachment #9053591 - Flags: approval-mozilla-release?
Attachment #9053591 - Flags: approval-mozilla-release+
Attachment #9053591 - Flags: approval-mozilla-beta?
Attachment #9053591 - Flags: approval-mozilla-beta+

Let's also check that the affected sites are fixed.

Flags: qe-verify+
Blocks: 1538970
QA Whiteboard: [qa-triaged]

Dennis, could you help us with some steps to verify this bug? Would few web compatibility check of the above mentioned websites from comment 9?

Flags: needinfo?(dschubert)

As discussed on Slack, please do check the bugs blocking this bug, each of them has STRs in them. I removed bug 1538970 from that list, because it was discovered too late for this bug, and has its own patch.

No longer blocks: 1538970
Flags: needinfo?(dschubert)

Hi, We tested on Windows 10, Ubuntu and MAC OsX systems with the latest versions of Release 66.0.2, Nightly 68.0a1 (2019-03-26)and Beta 67.0b6 and the issues blocking this Bug no longer occur in these versions. I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

There seems to be an extra period before the comma on this one, which may or may not make any difference:

*.officeapps-df.live.com.,

After upgrading to 66.0.2 on Win10, the online versions of Word and OneNote are still adding an extra space character.

Dennis, could Comment #19 be related to Comment #18?

Flags: needinfo?(dschubert)

jefmitch: interesting. Could you do me a favor? In the OneNote tab, open the Firefox Developer Tools console (Cmd-Opt-K on macOS, Ctrl-Alt-K on Win/Linux), and paste

Array.from(document.querySelectorAll("iframe")).map(f => f.contentWindow)

and copy-paste the output of that command to the bug here? Maybe there is another domain we need to capture.

(In reply to Mike Taylor [:miketaylr] from comment #20)

Dennis, could Comment #19 be related to Comment #18?

Unlikely, unless the person happens to use OneNote via that domain, which we'll know soon. :) Will file a follow-up to remove that point.

Flags: needinfo?(dschubert) → needinfo?(jefmitch)

Something with UBlock Origin was breaking it. It works after disabling that extension.

Ah, alright. Thanks for the report and the help anyway, much appreciated. :)

After getting the update with the X key bugfix.... Suddenly in our topdesk.net page we cant type words with a lower-case x anymore, and it sends the TAB key instead.

Could this be fixed soon?

Flags: needinfo?(dschubert)

Hey Sven, thanks for stopping by! We didn't hotfix any specific key, and also topdesk.net was not in the list of domains we added an exception for, so I unfortunately have no way to answer your question without knowing more details. If you have a webapp that's broken right now, we'd really like to know details. Do you mind filing a separate bug for that (this one is already closed), and could you provide us with a URL/account credentials so we could have a look at what's exactly going on there?

If you file a new bug, please needinfo me there as well, so I can make sure we work on that as soon as possible. :)

Flags: needinfo?(dschubert) → needinfo?(swolters)
Flags: in-qa-testsuite+
Duplicate of this bug: 1601028

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?
Root Cause: ? → Corner Case
You need to log in before you can comment on or make changes to this bug.