Closed Bug 1540095 Opened 2 years ago Closed 2 years ago

No update available on release update channel for 52.7.0 but current version is 60.x.x

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(thunderbird_esr6067+ fixed, thunderbird67 wontfix, thunderbird68 fixed)

RESOLVED FIXED
Thunderbird 68.0
Tracking Status
thunderbird_esr60 67+ fixed
thunderbird67 --- wontfix
thunderbird68 --- fixed

People

(Reporter: short_s, Assigned: rjl)

References

(Regression)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

Steps to reproduce:

Menu Help --> About Thunderbird

Actual results:

Thunderbird
52.7.0 (32-bit)
Thunderbird is up to date
You are currently on the release update channel

But this version is a year old and the current version is 60.x.x.

In the Error Console I see:

09:47:33.583 XML Parsing Error: syntax error
Location: https://aus5.mozilla.org/update/6/Thunderbird/52.7.0/20180322145026/WINNT_x86-msvc-x64/en-GB/release/Windows_NT%206.1.1.0%20(x64)/SSE3/default/default/update.xml?force=1
Line Number 1, Column 1: 1 update.xml:1:1

If I click on the "update.xml:1:1" link I see "No such locale 'en-GB' in platform 'WINNT_x86-msvc'"

I have exactly the same issue with Thunderbird 45.8.0 on another PC.

Expected results:

The latest version available on the release channel should have been displayed with an option to install.

Thanks for reporting this. May be a few days til I can get to it - hopefully someone else will beat me.

Flags: needinfo?(sancus)

I have also seen this, with TB 52.9.1 (32bit) on 64bit Windows 7 (as the reporter).
The TB is also a localized version, not en-US. Sadly, I haven't checked the Error console.

I assume this is an issue in balrog, which I don't have any access to nor know anything about, so can't really help with this.

Flags: needinfo?(sancus)

I get the same error with English Thunderbird 52.9.1 with Dutch language pack:

XML-parsefout: syntaxisfout
Locatie: https://aus5.mozilla.org/update/6/Thunderbird/52.9.1/20180709124824/WINNT_x86-msvc-x64/en-US/release/Windows_NT%2010.0.0.0%20(x64)/SSE3/default/default/update.xml?force=1
Regelnummer 1, kolom 1:

view-source on the specified location:
No such locale 'en-US' in platform 'WINNT_x86-msvc'

So this isn't only a localized version problem. I haven't tried on another platform, only Windows.

I can confirm there is problem with the Balrog release data for Thunderbird 60.6.0-bz2 and 60.6.1-bz2. I need to do further digging to find out why.

Assignee: nobody → rob
Status: UNCONFIRMED → NEW
Ever confirmed: true

I've also seen reports about problems updating from 45. Unfortunately I don't have handy references - so they perhaps are unrelated.

Component: Untriaged → General
Attached patch 36305.patchSplinter Review

bz2 MAR files did not get generated at all during the repackage steps for 60.6.0 and 60.6.1.

[Approval Request Comment]
Regression caused by (bug #): 1515652
User impact if declined: Updates from Thunderbird <60.0 to 60.x fail
Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):

Attachment #9065606 - Flags: review?(geoff)
Attachment #9065606 - Flags: approval-comm-esr60?
Target Milestone: --- → Thunderbird 60.0
Version: 52 Branch → 60
Regressions: 1515652
Regressed by: 1515652
No longer regressions: 1515652
Comment on attachment 9065606 [details] [diff] [review]
36305.patch

I'm told this is right despite it looking wrong. Okay…
Attachment #9065606 - Flags: review?(geoff) → review+

(In reply to Geoff Lankow (:darktrojan) from comment #8)

Comment on attachment 9065606 [details] [diff] [review]
36305.patch

I'm told this is right despite it looking wrong. Okay…

comm-esr60 is set up as a release branch (currently at https://searchfox.org/mozilla-central/source/taskcluster/taskgraph/decision.py#100-103)

PER_PROJECT_PARAMETERS = {
.......
    'comm-esr60': {
        'target_tasks_method': 'mozilla_esr60_tasks',
        'release_type': 'release',
    },

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4516cf2270f4
Use release type "release" instead of esr60 for repackage. r=darktrojan DONTBUILD

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: Thunderbird 60.0 → Thunderbird 68.0
Attachment #9065606 - Flags: approval-comm-esr60? → approval-comm-esr60+

Balrog data looks good for the bz2 MARs (and the regular ones as well).

You need to log in before you can comment on or make changes to this bug.