Closed Bug 1540231 Opened 1 year ago Closed 1 year ago

Crash in [@ mozilla::DAV1DDecoder::ReleaseDataBuffer]

Categories

(Core :: Audio/Video: Playback, defect, P1)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 + fixed
firefox68 + fixed

People

(Reporter: marcia, Assigned: achronop)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-111927c8-d015-4873-998b-e26110190329.

Lone crash so far on the 3-29 nightly. The crash has Moz crash reason: MOZ_RELEASE_ASSERT(((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))))

Top 10 frames of crashing thread:

0 xul.dll void mozilla::DAV1DDecoder::ReleaseDataBuffer dom/media/platforms/agnostic/DAV1DDecoder.cpp:76
1 xul.dll dav1d_ref_dec third_party/dav1d/src/ref.c:83
2 xul.dll dav1d_data_unref_internal third_party/dav1d/src/data.c:143
3 xul.dll dav1d_flush third_party/dav1d/src/lib.c:384
4 xul.dll static void close_internal third_party/dav1d/src/lib.c:437
5 xul.dll static class RefPtr<mozilla::MozPromise<bool, bool, 0> > mozilla::DAV1DDecoder::Shutdown::<unnamed-tag>::operator dom/media/platforms/agnostic/DAV1DDecoder.cpp:259
6 xul.dll nsresult mozilla::detail::ProxyFunctionRunnable<`lambda at z:/task_1553853102/build/src/dom/media/platforms/agnostic/DAV1DDecoder.cpp:258:44', mozilla::MozPromise<bool, bool, 0> >::Run xpcom/threads/MozPromise.h:1419
7 xul.dll nsresult mozilla::TaskQueue::Runner::Run xpcom/threads/TaskQueue.cpp:199
8 xul.dll nsresult nsThreadPool::Run xpcom/threads/nsThreadPool.cpp:244
9 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180

The failing assertion has been added in patch for bug 1493400.
:achronop, could you investigate please ?

Flags: needinfo?(achronop)
Assignee: nobody → achronop
Rank: 9
Priority: -- → P1
Pushed by achronopoulos@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1ec2362ecb9
Stop dispatching a task to the TaskQueue when we are already in it. r=jya
Duplicate of this bug: 1540579
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

[Tracking Requested - why for this release]:
This should be possible in beta too. The code fixed is identical between Nightly and beta.

Comment on attachment 9054828 [details]
Bug 1540231 - Stop dispatching a task to the TaskQueue when we are already in it. r?jya

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1493400
  • User impact if declined: Crash during AV1 palyback
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a small change and it has been verified on Nightly.
  • String changes made/needed:
Attachment #9054828 - Flags: approval-mozilla-beta?
Has Regression Range: --- → yes
Regressed by: 1493400

Comment on attachment 9054828 [details]
Bug 1540231 - Stop dispatching a task to the TaskQueue when we are already in it. r?jya

Crash fix for Dav1d playback, crashes stopped on Nightly just after the patch landed, uplift approved for 67 beta 9, thanks.

Attachment #9054828 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
See Also: → 1543350
You need to log in before you can comment on or make changes to this bug.