Closed Bug 1540579 Opened 1 year ago Closed 1 year ago

Assertion failure: ((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))), at src/dom/media/platforms/agnostic/DAV1DDecoder.cpp:76

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1540231
Tracking Status
firefox68 --- affected

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached video testcase.webm

Found with m-c 20190331-c06dfc552c64

Assertion failure: ((bool)(__builtin_expect(!!(!NS_FAILED_impl(rv)), 1))), at src/dom/media/platforms/agnostic/DAV1DDecoder.cpp:76

#0 get src/obj-firefox/dist/include/mozilla/RefPtr.h:268:27
#1 operator-> src/obj-firefox/dist/include/mozilla/RefPtr.h:298
#2 mozilla::DAV1DDecoder::ReleaseDataBuffer(unsigned char const*) src/dom/media/platforms/agnostic/DAV1DDecoder.cpp:71
#3 dav1d_ref_dec src/third_party/dav1d/src/ref.c:83:9
#4 dav1d_data_unref_internal src/third_party/dav1d/src/data.c:143:9
#5 close_internal src/third_party/dav1d/src/lib.c:518:9
#6 operator() src/dom/media/platforms/agnostic/DAV1DDecoder.cpp:259:5
#7 mozilla::detail::ProxyFunctionRunnable<mozilla::DAV1DDecoder::Shutdown()::$_14, mozilla::MozPromise<bool, bool, false> >::Run() src/obj-firefox/dist/include/mozilla/MozPromise.h:1419
#8 mozilla::TaskQueue::Runner::Run() src/xpcom/threads/TaskQueue.cpp:199:12
#9 nsThreadPool::Run() src/xpcom/threads/nsThreadPool.cpp:244:14
#10 non-virtual thunk to nsThreadPool::Run() src/xpcom/threads/nsThreadPool.cpp
#11 nsThread::ProcessNextEvent(bool, bool*) src/xpcom/threads/nsThread.cpp:1180:14
#12 NS_ProcessNextEvent(nsIThread*, bool) src/xpcom/threads/nsThreadUtils.cpp:482:10
#13 mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) src/ipc/glue/MessagePump.cpp:303:20
#14 RunInternal src/ipc/chromium/src/base/message_loop.cc:315:10
#15 RunHandler src/ipc/chromium/src/base/message_loop.cc:308
#16 MessageLoop::Run() src/ipc/chromium/src/base/message_loop.cc:290
#17 nsThread::ThreadFunc(void*) src/xpcom/threads/nsThread.cpp:454:11
#18 _pt_root src/nsprpub/pr/src/pthreads/ptthread.c:201:5
#19 start_thread (/lib/x86_64-linux-gnu/libpthread.so.0+0x76b9)
#20 clone /build/glibc-Cl5G7W/glibc-2.23/misc/../sysdeps/unix/sysv/linux/x86_64/clone.S:109
Flags: in-testsuite?

This looks like a possible duplication of Bug 1540231. Alex, do you agree?

Flags: needinfo?(achronop)
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(achronop)
Resolution: --- → DUPLICATE
Duplicate of bug: 1540231
You need to log in before you can comment on or make changes to this bug.