Closed Bug 1540517 Opened 5 months ago Closed 4 months ago

Installing more than three themes causes built-in themes to get bumped out of the Customize theme selection list

Categories

(Firefox :: Toolbars and Customization, defect, P2)

68 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + verified

People

(Reporter: ke5trel, Assigned: kmag)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Hamburger menu > Customize > Themes initially has three built-in themes and provision for up to six items. Installing more than three additional themes causes the built-in ones to be moved off the bottom of the list, with six themes installed there are no built-in themes in the list at all.

I can reproduce this as well.

No longer blocks: 1525511
Has Regression Range: --- → yes
Regressed by: 1525511
Component: Add-ons Manager → Toolbars and Customization
Product: Toolkit → Firefox

https://searchfox.org/mozilla-central/rev/8e0ea968308dd692ba5394b14e584234acf7d4ca/browser/components/customizableui/CustomizeMode.jsm#1358

This should be:

themes.sort((a, b) => importantThemes.has(b.id) - importantThemes.has(a.id));

instead of:

themes.sort((a, b) => importantThemes.has(b) - importantThemes.has(a));

But I'm puzzled why this wasn't caught by this test: https://searchfox.org/mozilla-central/source/browser/components/customizableui/test/browser_1007336_lwthemes_in_customize_mode.js

The order of themes is supposed to be tested from line 140.

See Also: → 1402981

[Tracking Requested - why for this release]:
Feature regressing that I think is on track for removal with 68, but needs to be either removed or fixed up for 68.

Priority: -- → P3

Changing the priority to p2 as the bug is tracked by a release manager for the current nightly.
See How Do You Triage for more information

Priority: P3 → P2

Kris, is this entire menu going away, or does it now longer list non-builtin themes, or does this just need fixing?

Blocks: rm-lwthemes
Flags: needinfo?(kmaglione+bmo)

I think I probably screwed up the sorting. We used to show a maximum of six items and always showed the built-in ones at the start of the list, so they never got cropped out.

Assignee: nobody → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I don't see any difference on latest Nightly 68.0a1 (2019-04-26), built-in themes are still being bumped out of the bottom of the list.

Attachment #9061164 - Attachment is patch: false
Attachment #9061164 - Attachment mime type: text/plain → image/png

(In reply to Kris Maglione [:kmag] from comment #6)

I think I probably screwed up the sorting. We used to show a maximum of six items and always showed the built-in ones at the start of the list, so they never got cropped out.

The old list was static with three built-in themes and three recommended themes.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

(In reply to Kestrel from comment #11)

Created attachment 9061165 [details]
Old theme customization list

(In reply to Kris Maglione [:kmag] from comment #6)

I think I probably screwed up the sorting. We used to show a maximum of six items and always showed the built-in ones at the start of the list, so they never got cropped out.

The old list was static with three built-in themes and three recommended themes.

Not if you installed more themes, but yeah, the three built-in themes always appeared first.

(In reply to Tim Nguyen :ntim from comment #12)

Not if you installed more themes, but yeah, the three built-in themes always appeared first.

That Comment 11 screencap is Firefox 66.0.3 with two user themes installed, none of them appear in the Customize list. I installed a further six themes and still none appear in the list.

(In reply to Kestrel from comment #13)

(In reply to Tim Nguyen :ntim from comment #12)

Not if you installed more themes, but yeah, the three built-in themes always appeared first.

That Comment 11 screencap is Firefox 66.0.3 with two user themes installed, none of them appear in the Customize list. I installed a further six themes and still none appear in the list.

If you install those 3 recommended themes, then you should see what I'm trying to mention especially since recommended themes are removed in FF 68.

(In reply to Tim Nguyen :ntim from comment #14)

If you install those 3 recommended themes, then you should see what I'm trying to mention especially since recommended themes are removed in FF 68.

I see now, recommended themes were added to the bottom of the list. Now installed themes are being added to the top. I also noticed when an installed theme is enabled it moves to the bottom of the list and can get bumped out as well. Ideally the currently enabled theme should always be visible in the list.

Blocks: 1547573

Let's move this to bug 1547573

Status: REOPENED → RESOLVED
Closed: 4 months ago4 months ago
Resolution: --- → FIXED
Flags: qe-verify+

Hi,

I tested this issue on Windows 10 with an old Nightly build 68.0a1 (20190330214418) and I was able to reproduce it.
I also tested it using the latest Nightly build 69.0a1 (2019-06-27) and latest Beta version 68.0b13 (20190624133534) and I'm not able to reproduce the issue. Based on this I will mark the bug as Verified.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.