Copy and paste from another application

RESOLVED DUPLICATE of bug 228920

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 228920
16 years ago
10 years ago

People

(Reporter: Andrew Thomas, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I am copying text from one application - namely Excel 97.

I can paste it into Word.

From there I can copy and paste it into a compose window of email.

I cannot paste it directly from Excel.

The same problem exists copying from Dyalog APL version 8 or 9.

It pastes into Word and then I can copy and paste into mail.

But not directly.

Mozilla needs to read the clipboard in all formats (RTF, Text, etc., graphics -
reported earlier and found to be reported by others).
To Apps
Assignee: ducarroz → blaker
Component: Composition → XP Apps: GUI Features
Product: MailNews → Browser
QA Contact: esther → paw
Target Milestone: --- → M1
Target Milestone: M1 → ---

Comment 2

16 years ago
I'm getting the same problem on linux - most applications cannot interact with
moz date on the clipboard. Presumably someone forgot to include all the sensible
formats that should be put on the clipboard?

Comment 3

15 years ago
Have similar problem. Cannot copy / paste directly from Word to Mail. Must paste
to text editor, then copy THAT to Mozilla mail.

Comment 4

15 years ago
Build 2003100804
Windows XP
AMD 1000

I can confirm this here too.

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
Created attachment 135389 [details]
within mail

When in mail (received & sending) I can highlight and select a word or sentence
to be copied, but I can't paste it either thru Ctl+V or from the drop down box.


You also can't paste it into another application such as WORDPAD, WORD or
anything else.

Comment 6

14 years ago
Ditto to all of the above.  I have been seeing this in Mozilla on Linux for the
past 2 years at least.

I now tend to keep a gedit window open at all times, to enable copy/paste from
another application into Mozilla.

There is another, related problem -- pasting more than about 4000 chars at once
into a web form under Mozilla (Windows or Linux) simply fails to do anything. 
Mozilla hangs for a second or two, then nothing happens.

There are certain sites I visit frequently into which I need to paste more text
than that.  I'm sorry to say I now keep a copy of <some other browser> running
at all times, to handle those sites.

Comment 7

14 years ago
There are also copy paste problems inside only Mozilla windows.

When I first copy the URL in the URL textfield (window #1) and paste it in a
different browser window (window #2) it works OK, but when I return to widnow #1
and I try to copy text it doesn't copy the text (also the context menu is
different).

Also keyboard navigation in the form of window #2 is then disabled (cursor keys,
home key, end key etc.)

On some occasions, when the cursor is in one textfield of a form, a Ctrl-V
action pastes it in another textfield of the same form (the textfield where the
previous paste action was made)

I've seen this in Mozilla 1.6 and 1.7beta, as well as FireFox 0.8 (all Win32) I
haven't checked mozilla <1.6, but it probably wasn't there, or i'd have noticed.

Product: Core → Mozilla Application Suite

Comment 8

13 years ago
Mozilla 1.7.5 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041217

I cannot copy from rxvt nor NEdit to Mozilla Mail Compose window.

Comment 9

13 years ago
*** Bug 205830 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
I have noticed that highlight/Copy/Paste more often that not fails on the first 'try'; the 2nd try always works fine though. No specifics in terms of where or when -Mozilla 1,5 just fails to perform any C/P ( email address/wording/anything)to another doc/email on the 1st go. 

Comment 11

12 years ago
copy and paste of addresses in the address bar doesn't always function properly. if two browsers are open, the i must repeat copy and past of the addresses to get it to work. 

Comment 12

12 years ago
If you had a problem with this bug, please try a TRUNK build and report whether it worked for you or didn't.  http://www.mozilla.org/developer/#builds  

This is probably fixed by Bug 228920 which mentions Excel.  If you report positive results we can dup to 228920.


(In reply to comment #10)
> I have noticed that highlight/Copy/Paste more often that not fails on the first
> 'try'; the 2nd try always works fine though. No specifics in terms of where or
> when -Mozilla 1,5 just fails to perform any C/P ( email
> address/wording/anything)to another doc/email on the 1st go. 

this, and comment 11 are a different problem.  Also possibly parts of comment 6 and comment 7.  You will want to look to other bugs for relief.
Summary: Copy and paste problem → Copy and paste from another application

Comment 13

12 years ago
WFM per reporter, kurt - so duping

*** This bug has been marked as a duplicate of 228920 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.