Computed value of border-radius shorthand with longhand using calc(mixed units)

RESOLVED DUPLICATE of bug 137688

Status

()

defect
RESOLVED DUPLICATE of bug 137688
2 months ago
2 months ago

People

(Reporter: bugzilla, Unassigned)

Tracking

(Blocks 1 bug, {testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 affected)

Details

Reporter

Description

2 months ago

Tests

http://www.gtalbot.org/BrowserBugsSection/CSS3Values/getComputedStyle-border-radius-001.html

http://www.gtalbot.org/BrowserBugsSection/CSS3Values/getComputedStyle-border-radius-003.html

Actual result for 001:
expected "calc(25% + 10px) calc(25% + 16px) 25% 25px / calc(25% + 20px) calc(25% + 16px) 25% 25px" but got ""

Actual result for 003:
expected "calc(1% + 1px) calc(2% + 2px) calc(3% + 3px) calc(4% + 4px) / calc(5% + 5px) calc(6% + 6px) calc(7% + 7px) calc(8% + 8px)" but got ""

Notes

  • Chromium 73.0.3683.75 passes both tests
  • Firefox 68.0a1 buildID=20190403060632 fails in both tests (only shorthand fails)
  • Both tests are complex
  • This is a followup to bug 1516454 because getComputedStyle-border-radius-001.html is an adaptation of the original test

https://chromium.googlesource.com/chromium/src/+/c825d655f6aaf73484f9d56e9012793f5b9668cc/third_party/WebKit/LayoutTests/css3/calc/getComputedStyle-border-radius.html

which I mentioned in bug 1516454

  • I want to eventually submit both tests to WPT repository and I do not intend to change their filenames when submitting them
  • I searched for a duplicate and did not find any.
Reporter

Updated

2 months ago
Blocks: 1376206
Keywords: testcase

See https://github.com/w3c/csswg-drafts/issues/2529, this was recently resolved to work.

Not a calc issue.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 137688
You need to log in before you can comment on or make changes to this bug.