Closed Bug 1541527 Opened 7 months ago Closed 6 months ago

Remove '-e10s' from treeherder group symbols and task labels

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

Details

Attachments

(2 files)

E10s has been the default configuration for a long time now. It's time to stop explicitly marking things with -e10s suffixes. Instead we should mark things that don't run with e10s.

I'm proposing -fc which stands for "fuel cell". The "electrolysis" of water is the process of using an electrical current to decompose water into oxygen and hydrogen. A "fuel cell" is a device that can convert hydrogen and oxygen into electricity, aka the reverse process as electrolysis. Therefore non-e10s things become -fc (other suggestions welcome :)).

Since e10s is the default configuration, we shouldn't explicitly mark things
with the "-e10s" suffix. Instead we should mark things that don't run with
'e10s. This patch removes '-e10s' from all treeherder group symbols and task
labels, adds the "-fc" suffix to tasks that are non-e10s.

The "electrolysis" of water is the process of using an electrical current to
decompose water into oxygen and hydrogen. A "fuel cell" is a device that can
convert hydrogen and oxygen into electricity, aka the reverse process as
electrolysis. Therefore "-fc" stands for "fuel cell" and is used to denote
things that run without e10s.

Attachment #9055540 - Attachment description: Bug 1541527 - Remove "-e10s" from treeherder group symbols and task labels → Bug 1541527 - Remove "-e10s" from treeherder group symbols and task labels, r?jmaher!, r?gbrown!
Attachment #9055540 - Attachment description: Bug 1541527 - Remove "-e10s" from treeherder group symbols and task labels, r?jmaher!, r?gbrown! → Bug 1541527 - Remove "-e10s" from treeherder group symbols and task labels, r?jmaher!,gbrown!
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6c39f570b1f
[ci] Remove unused raptor chrome group symbols, r=rwood
https://hg.mozilla.org/integration/autoland/rev/99e40003ff9a
Remove "-e10s" from treeherder group symbols and task labels, r=jmaher,gbrown
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/3f1eb0d82f7c
Port bug 1541527 - Update treeherder test group symbols. rs=bustage-fix
Regressions: 1544858
Depends on: 1549669
No longer depends on: 1549669
Regressions: 1549669
You need to log in before you can comment on or make changes to this bug.