Closed Bug 1541582 Opened 1 year ago Closed 1 year ago

If an uplift request answers Yes to needing manual QA, the qe-verify flag should be set to '+', not '?'

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: MattN, Assigned: MattN)

References

(Depends on 1 open bug, Regression)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review

See https://bugzilla.mozilla.org/show_bug.cgi?id=1538952#a777766_305228 where it was incorrectly reset to '?'.

Definitions of the flag from the tooltip:

qe-verify: ? ➜ request to assess whether the bug should be tested manually
qe-verify: + ➜ request to verify the bug manually
qe-verify: – ➜ the bug will not/can not be verified manually

Attached file GitHub Pull Request

Looks like the definition of the qe-verify flag is about to change. See Bug 1528106.

Blocks: 1527178
Depends on: 1528106
No longer regressed by: 1527178

IMO the behaviour seen in https://bugzilla.mozilla.org/show_bug.cgi?id=1538952#a777766_305228 (where the flag was reset) is a regression so not sure why you removed bug 1527178 from the regressed by field.

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #2)

Looks like the definition of the qe-verify flag is about to change. See Bug 1528106.

That's been stalled for a month so not worth the regression in the meantime IMO since it's a 1 character fix to change in that bug.

This is not a regression because Bug 1527178 is a new feature. I’ll merge the PR now.

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

(In reply to Kohei Yoshino [:kohei] (Bugzilla UX) (FxSiteCompat) from comment #5)

This is not a regression because Bug 1527178 is a new feature. I’ll merge the PR now.

New features can cause regressions so that argument doesn't make much sense. I could have summarized the bug as "qe-verify flag gets reset to '?' when I request an uplift with QA verification"… would you then agree that this is a regression?

Now I understand your point! (and the Regressed by field I’ve added works great)

No longer blocks: 1527178
Regressed by: 1527178
Component: Extensions: FlagTypeComment → Extensions
You need to log in before you can comment on or make changes to this bug.