Closed Bug 1541772 Opened 10 months ago Closed 8 months ago

Crash in [@ mozilla::dom::`anonymous namespace'::PrepareDatastoreOp::DatabaseWork]

Categories

(Core :: Storage: localStorage & sessionStorage, defect, P3, critical)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox67 --- unaffected
firefox68 --- disabled
firefox69 --- fixed

People

(Reporter: janv, Assigned: janv)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-747f53c0-d56e-4aae-8195-71dc40190404.

Top 10 frames of crashing thread:

0 xul.dll nsresult mozilla::dom::`anonymous namespace'::PrepareDatastoreOp::DatabaseWork dom/localstorage/ActorsParent.cpp:6330
1 xul.dll nsresult mozilla::dom::`anonymous namespace'::PrepareDatastoreOp::NestedRun dom/localstorage/ActorsParent.cpp:6660
2 xul.dll nsresult mozilla::dom::`anonymous namespace'::LSRequestBase::Run dom/localstorage/ActorsParent.cpp:5806
3 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
4 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:482
5 xul.dll mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:303
6 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
7 xul.dll static void nsThread::ThreadFunc xpcom/threads/nsThread.cpp:454
8 nss3.dll static void _PR_NativeRunThread nsprpub/pr/src/threads/combined/pruthr.c:397
9 nss3.dll unsigned int pr_root nsprpub/pr/src/md/windows/w95thred.c:137

Blocks: 1540402
Priority: -- → P3

This started showing up again in nightly 20190519213707.
Crash reason MOZ_RELEASE_ASSERT(mUsage == 0)

this crash seems to continue with the signature from bug 1552756 in recent nightly builds - on 68.0b it's only hitting devedition users.

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #2)

A Reddit user ran into this when opening Instagram: bp-7e81ae1c-095c-4506-b1fc-1d63b0190521
https://www.reddit.com/r/firefox/comments/brc28c/visiting_some_websites_crashes_firefox_nightly/

Did you see this, janv?

Flags: needinfo?(jvarga)

No, but the assertion has been converted back to MOZ_ASSERT, so it shouldn't crash in optimized builds anymore.

Flags: needinfo?(jvarga)

(In reply to Jan Varga [:janv] from comment #5)

No, but the assertion has been converted back to MOZ_ASSERT, so it shouldn't crash in optimized builds anymore.

I'm the reddit user "Jan Andre Ikenmeyer" mentioned and it seems to be fixed for me now. Doesn't crash anymore.

Ok, but I landed the change only recently so it will take several hours to appear in a nightly build.

Regressed by: 1540401

This is now fixed. See bug 1540401 comment 35.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Assignee: nobody → jvarga
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.