w3.org - Can not display test complex4.

RESOLVED DUPLICATE of bug 184159

Status

()

Core
MathML
--
major
RESOLVED DUPLICATE of bug 184159
15 years ago
15 years ago

People

(Reporter: S-O Westberg, Assigned: rbs)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a+) Gecko/2002062508 can not display
MathML test complex4. Then after it displays the error message it say it transfer
data from the site but it do not transfer a single byte. Pressing stop stops
the "fake transfer" . 


XML Parsing Error: mismatched tag. Expected: </math>.
Location:
http://www.w3.org/Math/testsuite/testsuite/TortureTests/Complexity/complex4.xml
Line Number 864, Column 11:        </condition>
----------^

To show the bug just go to.
http://www.w3.org/Math/testsuite/testsuite/TortureTests/Complexity/complex4.xml
Fetching the source via wget shows thatthe page has:

<math xmlns="http://www.w3.org/1998/Math/MathML">
          <apply>
            <and/>
            <reln>
              <gt/>
              <ci>x</ci>
              <cn>0</cn>
            </reln>
            <reln>
              <lt/>
              <ci>x</ci>
              <cn>1</cn>
            </reln>
          </apply>
        </condition>
      </math>

So in fact the </condition> is out of place, the document is not well-formed,
and the parse error is correct.  The document needs to be fixed.  Where is this
document linked from?
Assignee: rbs → bclary
Severity: normal → major
Component: MathML → Authors
OS: Windows 98 → All
Product: Browser → Tech Evangelism
QA Contact: ian → mgalli
Hardware: PC → All
Summary: Can not display test complex4. → Can not display test complex4.
Version: other → unspecified
(Reporter)

Comment 2

15 years ago
What about the second part of my bug. Where Mozilla say it transfer fom the site
when it does not after it has displayed the error message. Is this how it should
work?
Ah, my apologies.  I missed that part...  Thank you for pointing it out again...
Bug 154438 filed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
sent message to the mailing list. let's see what they say/do.
Status: NEW → ASSIGNED
Summary: Can not display test complex4. → w3.org - Can not display test complex4.
Target Milestone: --- → Sep

Comment 5

15 years ago
Locks me up on on 20021205 1.3a win2k so I guess the non well formed problem is
fixed. Assigning to mathml for the lock up.
Assignee: bclary → rbs
Status: ASSIGNED → NEW
Component: Authors → MathML
Product: Tech Evangelism → Browser
QA Contact: mgalli → ian
Target Milestone: Sep → ---
Version: unspecified → Trunk
(Assignee)

Comment 6

15 years ago
WFM with Nav 7.0. Suspecting a XSLT delicacy on the trunk now. My radars seem to
suggest a deadlock while the document is being mangled by XSLT.
sorry for dupping the "wrong" way, but this bug has morphed and the other one
contains more info

*** This bug has been marked as a duplicate of 184159 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.