Closed Bug 1541972 Opened 10 months ago Closed 8 months ago

Crash in [@ mozilla::dom::(anonymous namespace)::QuotaClient::InitOrigin]

Categories

(Core :: Storage: localStorage & sessionStorage, defect, P1, critical)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + fixed

People

(Reporter: janv, Assigned: janv)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-e14e10fc-8579-4730-9184-eebad0190404.

Top 10 frames of crashing thread:

0 XUL mozilla::dom:: dom/localstorage/ActorsParent.cpp:7661
1 XUL mozilla::dom::quota::QuotaManager::InitializeOrigin dom/quota/ActorsParent.cpp:4094
2 XUL mozilla::dom::quota::QuotaManager::InitializeRepository dom/quota/ActorsParent.cpp:3963
3 XUL mozilla::dom::quota::QuotaManager::EnsureTemporaryStorageIsInitialized dom/quota/ActorsParent.cpp:5321
4 XUL mozilla::dom::quota::QuotaManager::EnsureOriginIsInitializedInternal dom/quota/ActorsParent.cpp:5248
5 XUL mozilla::dom:: dom/quota/ActorsParent.cpp:5210
6 XUL mozilla::dom:: dom/localstorage/ActorsParent.cpp:5806
7 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
8 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:482
9 XUL mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:333

Blocks: 1540402

This could be fixed by patch in bug 1542104.

Priority: -- → P1

Looks like this signature is showing up again in yesterday's nightly builds, on linux and mac, as a startup crash.

Yeah, it was already backed out. See bug 1540401 comment 15.

Based on the lack of crashes since https://hg.mozilla.org/mozilla-central/rev/d134fc3b9e29 it looks like we're in the clear here?

Flags: needinfo?(jvarga)

I landed the patch again (bug 1540401), we should wait a bit longer.

Flags: needinfo?(jvarga)

Yeah, looks like it was fixed for good.

Assignee: nobody → jvarga
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Status: RESOLVED → REOPENED
Crash Signature: [@ mozilla::dom::(anonymous namespace)::QuotaClient::InitOrigin] → [@ mozilla::dom::(anonymous namespace)::QuotaClient::InitOrigin] [@ mozilla::dom::`anonymous namespace'::QuotaClient::InitOrigin]
Resolution: FIXED → ---
Regressed by: 1540401

This is now fixed. See bug 1540401 comment 39.

Status: REOPENED → RESOLVED
Closed: 9 months ago8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.