Permafailing Android artifact Nightly jobs (only running on Try) Android 4.0 API16+ opt and Android 5.0 AArch64 opt

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
a month ago
a month ago

People

(Reporter: alexandru.ionescu, Assigned: chmanchester)

Tracking

(Regression)

unspecified
mozilla68
Unspecified
Android

Firefox Tracking Flags

(firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

[task 2019-03-12T17:15:23.466Z] 17:15:23 INFO - 17:15:23 INFO - Multi-locale packaging requires the full (non-artifact) 'RecursiveMake' build backend; got ['FasterMake+RecursiveMake'].
[task 2019-03-12T17:15:23.481Z] 17:15:23 INFO - 17:15:23 ERROR - Return code: 1

Can running/requesting those jobs be prevented?

Summary: Android 4.0 API16+ opt and Android 5.0 AArch64 opt failing with Na → Permafailing Android artifact Nightly jobs (only running on Try) Android 4.0 API16+ opt and Android 5.0 AArch64 opt
See Also: → android-pgo, 1535364

chmanchester, these Try errors appear to be related to Android PGO configuration.

Type: task → defect
Flags: needinfo?(cmanchester)
OS: Unspecified → Android

The API16+ build is failing due to the PGO configuration, but the AArch64 build is failing for another reason. I don't think we've ever intended to replace Nightly builds with artifact builds in automation, the artifact code doesn't know to look for them, so we may end up with artifacts from an opt or pgo build. That might work ok, but I don't think we're expecting it. For shippable everything works alright, for Android nightlies for now I think we should just stop nightly builds from being converted into artifact builds.

Assignee: nobody → cmanchester
Flags: needinfo?(cmanchester)

(In reply to Chris Manchester (:chmanchester) from comment #3)

The API16+ build is failing due to the PGO configuration, but the AArch64 build is failing for another reason. I don't think we've ever intended to replace Nightly builds with artifact builds in automation, the artifact code doesn't know to look for them, so we may end up with artifacts from an opt or pgo build. That might work ok, but I don't think we're expecting it. For shippable everything works alright, for Android nightlies for now I think we should just stop nightly builds from being converted into artifact builds.

We used to have a flag for this, but I think post Bug 1530908 we do not. glandium, how do we manage this after your earlier work?

Flags: needinfo?(mh+mozilla)
Regressed by: 1530908

The new check is here: https://searchfox.org/mozilla-central/rev/8d78f219702286c873860f39f9ed78bad1a6d062/taskcluster/taskgraph/transforms/build.py#156

I have a patch that adds a nightly check there that looks fine on try.

Flags: needinfo?(mh+mozilla)

Comment 7

a month ago
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17b96c33164e
Don't replace 'nightly' jobs with artifact builds on try. r=glandium

Comment 8

a month ago
bugherder
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.