[about:addons] More Options button is not opening from the first click

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
4 months ago
4 months ago

People

(Reporter: cbadescu, Assigned: mstriemer)

Tracking

(Blocks 1 bug, Regression)

Trunk
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 disabled, firefox67 disabled, firefox68 verified)

Details

Attachments

(3 attachments)

[Affected versions]:

  • Firefox 68.0a1 (20190408193006)
  • Firefox 67.0b9(20190408123043)

[Affected platforms]:

  • Win 7 64-bit
  • Ubuntu 14.04.LTS 32-bit

[Prerequisites]

  • Set the preference extensions.htmlaboutaddons.enabled to true and restart the browser

[Steps to reproduce]:
1.Install an extension from about:addons.
2.Select Extensions from about:addons.
3.In Manage Your Extensions, hover over the more options menu button.
4.Click on it.

[Expected results]:

  • The the drop-down menu opens.

[Actual results]:

  • After clicking once, the drop-down menu is not opening, only on the second click.

[Notes]

  • When you click the second time, if you use the right-click button, the drop-down menu and the context menu opens at the same time, hiding the drop-down menu, under the context menu.

  • This issue is not reproducing on Mac OS X 10.14.1.

Please see the attached video.

Summary: More Options button is not opening from the first click → [about:addons] More Options button is not opening from the first click
Blocks: 1533795
No longer blocks: 1525193
Regressed by: 1525193
Priority: -- → P1
Assignee: nobody → mstriemer

There was a bug where the panel would be hidden on the first click on Windows (and I think Linux, too). This was happening because the focusin event would trigger after mousedown and hide the panel on the first click. Then the button would have focus and we wouldn't get a focusin on the second click.

This updates the focusin handler to check if this is the first focusin event, and ignore it if the event target matches our triggering event's target.

Attachment #9060284 - Attachment description: Show more options menu on first click r?Gijs → Show more options menu on first click
Attachment #9060284 - Attachment description: Show more options menu on first click → Bug 1543080 - Show more options menu on first click
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/92e638c435da
Show more options menu on first click r=Gijs
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Behind a pref, disabled for 67.

Posted image Bug1543080.gif

This issue is verified as fixed on Firefox 68.0a1 (20190501215533) under Win 7 64-bit and Ubuntu 14.04.LTS 32-bit.

Please see the attached video.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.