[about:addons] Move add-on's list actions into a more options menu

VERIFIED FIXED in Firefox 67

Status

()

enhancement
P1
normal
VERIFIED FIXED
5 months ago
2 months ago

People

(Reporter: mstriemer, Assigned: mstriemer)

Tracking

(Blocks 1 bug, Regressed 1 bug)

Trunk
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 verified, firefox68 verified)

Details

(Whiteboard: [feature-scope])

Attachments

(5 attachments)

Assignee

Description

5 months ago

The Disable and Remove buttons should be behind a more options popup [1] instead of being always visible buttons.

[1] https://mozilla.invisionapp.com/share/W2DW6NYX9#/screens/256825113

Whiteboard: [feature-scope]
Assignee

Updated

4 months ago
Assignee: nobody → mstriemer

Comment 1

4 months ago

As a long-time Firefox user, I'd prefer to keep the 3 separate buttons for

  1. enable/disable extension (toggle)
  2. remove extension
  3. extension options

I often change the extension options from the Add-ons manager (this would now take 3 clicks instead of 1!) or quickly enable/disable several extensions for debugging purposes.

For fluent add-on management, efficiency is more important than esthetics. Why don't you provide three small buttons with an icon to save enough space for the add-on title and description? See also the closing words and comments on https://www.ghacks.net/2019/02/19/a-first-look-at-firefoxs-updated-add-ons-manager/. Other people share this need for efficiency.

Thank you for taking this into consideration.

Blocks: 1533795
No longer blocks: 1505924
Priority: P2 → P1

Comment 5

3 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2e1a91cd78fe
Rename page-action.svg to more.svg, move to toolkit r=dao
https://hg.mozilla.org/integration/autoland/rev/e08f9ad9fcbb
Move actions to more options menu in HTML about:addons r=Gijs,flod
https://hg.mozilla.org/integration/autoland/rev/77dbfa3a6e55
HTML ghost button styles r=dao
Assignee

Comment 8

3 months ago

The extension management options should now be in the more options menu (... button). The Disable/Enable and Remove buttons should work as expected. The More Options button is currently a placeholder until bug 1525173 lands.

Updated

3 months ago
Depends on: 1542529

Comment 9

3 months ago
Posted image Bug1525193.gif

This issue is verified as fixed on Firefox 68.0a1 (20190408193006) and Firefox 67.0b9 - build1 (20190408123043) under Win 7 64-bit and Mac OS X 10.14.1.

Please see the attached video.

Updated

3 months ago
Status: RESOLVED → VERIFIED

Updated

3 months ago
Depends on: 1543080

A little while ago I filed a but to make the option "Install Add-on From File…" and other add-on options more easily accessible, because at the moment it is only available from the popup menu under the Tools button in the old add-ons manager. This makes it hard to access the feature by keyboard only and possibly also for people with a screen reader (bug 1526232).

With this new implementation where the buttons per add-on are replaced by a single clickable element which hides the menuitems it seems like you do it the other way around and make the other add-on buttons harder to reach by keyboard. This will only be worse when it will be converted to HTML.

Please consider also adding real menus/menuitems to access add-on functions.

Summary: Move add-on's list actions into a more options menu → [about:addons] Move add-on's list actions into a more options menu
Assignee

Updated

2 months ago
No longer depends on: 1543080
Regressions: 1543080
Assignee

Updated

2 months ago
No longer depends on: 1542529
Regressions: 1542529
You need to log in before you can comment on or make changes to this bug.