Open Bug 1543355 Opened 1 year ago Updated 6 months ago

Intermittent Android 4.3 org.mozilla.geckoview.test.ContentDelegateTest.download | status -2

Categories

(GeckoView :: General, defect, P3)

ARM
Android
defect

Tracking

(geckoview66 wontfix, firefox-esr60 wontfix, firefox66 wontfix, firefox67 wontfix, firefox68 disabled, firefox69 fix-optional, firefox70 fix-optional)

REOPENED
Tracking Status
geckoview66 --- wontfix
firefox-esr60 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- disabled
firefox69 --- fix-optional
firefox70 --- fix-optional

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [stockwell disabled])

Attachments

(1 file)

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=239290256&repo=autoland

https://queue.taskcluster.net/v1/task/MKaIGWF7TUavLKGbA0hyPg/runs/0/artifacts/public/logs/live_backing.log

[task 2019-04-10T09:16:32.720Z] 09:16:32 INFO - TEST-START | org.mozilla.geckoview.test.ContentDelegateTest.download
[task 2019-04-10T09:18:35.183Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2019-04-10T09:18:35.183Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=28
[task 2019-04-10T09:18:35.184Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.ContentDelegateTest
[task 2019-04-10T09:18:35.184Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2019-04-10T09:18:35.185Z] 09:18:35 INFO - org.mozilla.geckoview.test | Error in download(org.mozilla.geckoview.test.ContentDelegateTest):
[task 2019-04-10T09:18:35.185Z] 09:18:35 INFO - org.mozilla.geckoview.test | org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2019-04-10T09:18:35.185Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:56)
[task 2019-04-10T09:18:35.185Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-04-10T09:18:35.185Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-04-10T09:18:35.186Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:154)
[task 2019-04-10T09:18:35.186Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForInitialLoad(GeckoSessionTestRule.java:1314)
[task 2019-04-10T09:18:35.187Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1263)
[task 2019-04-10T09:18:35.187Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1259)
[task 2019-04-10T09:18:35.188Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1231)
[task 2019-04-10T09:18:35.189Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1421)
[task 2019-04-10T09:18:35.190Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-04-10T09:18:35.191Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-04-10T09:18:35.191Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-04-10T09:18:35.192Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-04-10T09:18:35.193Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-04-10T09:18:35.193Z] 09:18:35 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-04-10T09:18:35.194Z] 09:18:35 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-04-10T09:18:35.194Z] 09:18:35 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-04-10T09:18:35.194Z] 09:18:35 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-04-10T09:18:35.195Z] 09:18:35 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-04-10T09:18:35.195Z] 09:18:35 INFO - org.mozilla.geckoview.test |
[task 2019-04-10T09:18:35.195Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=149
[task 2019-04-10T09:18:35.196Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutException: Timed out after 120000ms
[task 2019-04-10T09:18:35.196Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils$TimeoutRunnable.run(UiThreadUtils.java:56)
[task 2019-04-10T09:18:35.196Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-04-10T09:18:35.197Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-04-10T09:18:35.197Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.loopUntilIdle(UiThreadUtils.java:154)
[task 2019-04-10T09:18:35.197Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForInitialLoad(GeckoSessionTestRule.java:1314)
[task 2019-04-10T09:18:35.198Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForOpenSession(GeckoSessionTestRule.java:1263)
[task 2019-04-10T09:18:35.198Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.openSession(GeckoSessionTestRule.java:1259)
[task 2019-04-10T09:18:35.198Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.prepareStatement(GeckoSessionTestRule.java:1231)
[task 2019-04-10T09:18:35.199Z] 09:18:35 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$3$1.run(GeckoSessionTestRule.java:1421)
[task 2019-04-10T09:18:35.199Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1719)
[task 2019-04-10T09:18:35.199Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:730)
[task 2019-04-10T09:18:35.200Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:92)
[task 2019-04-10T09:18:35.200Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:137)
[task 2019-04-10T09:18:35.201Z] 09:18:35 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:5103)
[task 2019-04-10T09:18:35.201Z] 09:18:35 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invokeNative(Native Method)
[task 2019-04-10T09:18:35.201Z] 09:18:35 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Method.java:525)
[task 2019-04-10T09:18:35.202Z] 09:18:35 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:737)
[task 2019-04-10T09:18:35.202Z] 09:18:35 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:553)
[task 2019-04-10T09:18:35.203Z] 09:18:35 INFO - org.mozilla.geckoview.test | at dalvik.system.NativeStart.main(Native Method)
[task 2019-04-10T09:18:35.203Z] 09:18:35 INFO - org.mozilla.geckoview.test |
[task 2019-04-10T09:18:35.203Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=download
[task 2019-04-10T09:18:35.203Z] 09:18:35 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2019-04-10T09:18:35.204Z] 09:18:35 WARNING - TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.ContentDelegateTest.download | status -2
[task 2019-04-10T09:18:35.204Z] 09:18:35 INFO - TEST-INFO took 122474ms

Priority: P5 → P3

This is now on disable recommended bugs list; Chris could you please redirect this to someone to take a look what's going on here? It has failed 168 times so far in the last 7 days, all on android-em-4-3-arm pgo: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-04-12&endday=2019-04-19&tree=trunk&bug=1543355

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=241388240&repo=autoland&lineNumber=1871

Flags: needinfo?(cpeterson)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

(In reply to Cosmin Sabou [:CosminS] from comment #7)

This is now on disable recommended bugs list; Chris could you please redirect this to someone to take a look what's going on here?

Thanks for the heads up. I will send this bug back to GeckoView triage for prioritization (though triage is not until next Thursday).

Flags: needinfo?(cpeterson)
OS: All → Android
Priority: P3 → --
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

Over the last 7 days there are 47 failures on this bug. These happen only on android-em-4-3-armv7-api16.

Here is the latest failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=243134597&repo=mozilla-central&lineNumber=1844

Flags: needinfo?(cpeterson)

Agi is testing whether moving these geckoview-junit tests from the slow Android ARM emulators to the faster Android x86_64 servers makes all these timeout failures go away.

Flags: needinfo?(cpeterson)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork]
Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9d6ef7336399
Disable org.mozilla.geckoview.test.ContentDelegateTest.download for frequent failures. r=gbrown
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---
Whiteboard: [stockwell disable-recommended]
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2742b0a517fb
Disable org.mozilla.geckoview.test.ContentDelegateTest.download for frequent failures. r=gbrown
Whiteboard: [stockwell disabled]
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/4e9097a10c77
Move early return in org.mozilla.geckoview.test.ContentDelegateTest.download on Android pgo to start of test to avoid timeouts. a=move-of-test-disabling

This occurs even if the first command in that subtest is assumeThat and should skip the remaining statements. Fallout from the titleChange test before?

This bug failed 90 times in the last 7 days. Occurs on android-em-4-3-armv7-api16 on pgo build types.

Recent log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=250731194&repo=autoland&lineNumber=1825

Over the last 7 days there are 108 failures present on this bug. These happen only on android-em-4-3-armv7-api16.

Here is the most recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=252062488&repo=autoland&lineNumber=1838

Flags: needinfo?(cpeterson)

Over the last 7 days there are 108 failures present on this bug. These happen only on android-em-4-3-armv7-api16.

Thanks for the heads up. The GeckoView team is looking to move these tests to an Android x86_64 emulator that should make these intermittent failures go away.

Flags: needinfo?(cpeterson)
Hardware: Unspecified → ARM

This bug failed 62 times in the last 7 days. Occurs on android-em-4-3-armv7-api16 on pgo build types.

Recent log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=253730024&repo=mozilla-inbound&lineNumber=1834

Over the last 7 days there are 36 failures on this bug. These happen only on android-em-4-3-armv7-api16.

Here is the most recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=255337470&repo=autoland&lineNumber=1838

Flags: needinfo?(cpeterson)

(In reply to Stefan Hindli [:stefan_hindli] from comment #49)

Over the last 7 days there are 36 failures on this bug. These happen only on android-em-4-3-armv7-api16.

Agi just enabled junit tests on Android 7.0 x86-64 (bug 1553515), which should be more stable than the ARM emulator. Once x86-64 is looking good on m-c, we will stop running the junit tests on ARM.

Flags: needinfo?(cpeterson)

I'm editing a bunch of GeckoView bugs. If you'd like to filter all this bugmail, search and destroy emails containing this UUID:

e88a5094-0fc0-4b7c-b7c5-aef00a11dbc9

Priority: P2 → P3

Happy to take a patch for 70, but since this is already triaged and set to P3 priority I'm setting it as fix-optional.
That will remove the bug from weekly regression triage.

You need to log in before you can comment on or make changes to this bug.