Closed Bug 1553515 Opened 4 months ago Closed Last month

Make geckoview-junit pass reliably on x86_64

Categories

(GeckoView :: General, defect, P2)

x86_64
Android
defect

Tracking

(firefox69 wontfix, firefox70 fixed)

RESOLVED FIXED
mozilla70
Tracking Status
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: Agi, Assigned: Agi)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(26 files, 2 obsolete files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

Our arm tests run in the emulator which is really slow (about 30-45 times slower than native x86_64 emulator). We should move to x86_64 but right now the tests do not pass. This tracks work to make them pass reliably and switch over.

Summary: [meta] Make geckoview-junit pass reliably on x86_64 → Make geckoview-junit pass reliably on x86_64
Assignee: nobody → agi
Blocks: 1489669
OS: All → Android
Priority: -- → P1
Hardware: Unspecified → x86_64

Sometime the geolocation test fails because the position is not retrieved
quickly enough, this is OK as we're just trying to make sure that the
permission is correct.

Reusing sessions doesn't actually save that much time and avoids a lot of
hard-to-debug intermittents.

Believe it or not this helps with getting PageStop events more reliably.

This method makes so that we don't add a GeckoSession to a HashMap before
changing its hashCode() by calling readFromParcel.

This helps making this test more reliable.

Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/80512ab53f44
Call geckoview.startup on DOMContentLoaded. r=geckoview-reviewers,snorp

Adding 'leave-open', since I only landed one patch in the series.

Keywords: leave-open
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2889a14d1858
Don't use reflection in ContentDelegateTest. r=snorp
https://hg.mozilla.org/integration/autoland/rev/5435965d4c04
Wait to load a page in crashContentMultipleSessions. r=snorp
https://hg.mozilla.org/integration/autoland/rev/9fca72dc9b74
Use environment.defaultTimeoutMillis in tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/ac9c129bfbcc
Account for errors in PermissionDelegateTest.geolocation. r=snorp
https://hg.mozilla.org/integration/autoland/rev/316439eec048
Use javascript to track scrolling instead of ScrollDelegate. r=snorp
https://hg.mozilla.org/integration/autoland/rev/b2b2a5d55e93
Never reuse session. r=snorp
https://hg.mozilla.org/integration/autoland/rev/a44d58f58ce4
Add FOREGROUND_SERVICE for CrashTest. r=snorp
https://hg.mozilla.org/integration/autoland/rev/c4287e1c1485
Use lambads in GeckoResultTest for readability. r=snorp
https://hg.mozilla.org/integration/autoland/rev/5a9d7367edb7
Add waitForCondition. r=snorp
https://hg.mozilla.org/integration/autoland/rev/9a058acc45e8
Add GeckoResult.accept. r=snorp
https://hg.mozilla.org/integration/autoland/rev/7a1fb1222e52
Replace loopUntilIdle -> waitForCondition. r=snorp
https://hg.mozilla.org/integration/autoland/rev/879397260d90
Make sure runtime has started before running tests. r=snorp
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c29929cc67c
Don't use reflection in ContentDelegateTest. r=snorp
https://hg.mozilla.org/integration/autoland/rev/2b1f78e255ce
Wait to load a page in crashContentMultipleSessions. r=snorp
https://hg.mozilla.org/integration/autoland/rev/3d1a0d412dfd
Use environment.defaultTimeoutMillis in tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/9e9dc0e7afb3
Account for errors in PermissionDelegateTest.geolocation. r=snorp
https://hg.mozilla.org/integration/autoland/rev/d3734e6fe22a
Use javascript to track scrolling instead of ScrollDelegate. r=snorp
https://hg.mozilla.org/integration/autoland/rev/84414ac99629
Never reuse session. r=snorp
https://hg.mozilla.org/integration/autoland/rev/dbbb8fe1ecfb
Add FOREGROUND_SERVICE for CrashTest. r=snorp
https://hg.mozilla.org/integration/autoland/rev/98cf5b0cadf1
Use lambads in GeckoResultTest for readability. r=snorp
https://hg.mozilla.org/integration/autoland/rev/faa333bb64e2
Add waitForCondition. r=snorp
https://hg.mozilla.org/integration/autoland/rev/8fe9f5d7fef9
Add GeckoResult.accept. r=snorp
https://hg.mozilla.org/integration/autoland/rev/bbc184402f36
Replace loopUntilIdle -> waitForCondition. r=snorp
https://hg.mozilla.org/integration/autoland/rev/080d770c7b35
Make sure runtime has started before running tests. r=snorp

My bad sorry. Fixed and relanded.

Flags: needinfo?(agi)

Looks like we need to fix https://bugzilla.mozilla.org/show_bug.cgi?id=1533888 before landing this.

Flags: needinfo?(agi)
Depends on: 1533888
Attachment #9067559 - Attachment description: Bug 1553515 - Always send onPageStop for about:blank. → Bug 1553515 - Always send navigation events for about:blank.
Attachment #9067569 - Attachment is obsolete: true
Attachment #9067570 - Attachment is obsolete: true
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/604f9f7fa587
Don't use reflection in ContentDelegateTest. r=snorp
https://hg.mozilla.org/integration/autoland/rev/36e8ca1b4b70
Wait to load a page in crashContentMultipleSessions. r=snorp
https://hg.mozilla.org/integration/autoland/rev/2f2d90fccda9
Use environment.defaultTimeoutMillis in tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/27c75ff5fd96
Account for errors in PermissionDelegateTest.geolocation. r=snorp
https://hg.mozilla.org/integration/autoland/rev/f48fe89dbedd
Use javascript to track scrolling instead of ScrollDelegate. r=snorp
https://hg.mozilla.org/integration/autoland/rev/b53f9d993a20
Never reuse session. r=snorp
https://hg.mozilla.org/integration/autoland/rev/f753025bb55b
Add FOREGROUND_SERVICE for CrashTest. r=snorp
https://hg.mozilla.org/integration/autoland/rev/6054b4310a45
Use lambads in GeckoResultTest for readability. r=snorp
https://hg.mozilla.org/integration/autoland/rev/ce691a380b23
Add waitForCondition. r=snorp
https://hg.mozilla.org/integration/autoland/rev/42a44c814b6f
Add GeckoResult.accept. r=snorp
https://hg.mozilla.org/integration/autoland/rev/547ff97b194e
Replace loopUntilIdle -> waitForCondition. r=snorp
https://hg.mozilla.org/integration/autoland/rev/c5039a265a46
Make sure runtime has started before running tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/67f2e46bdb98
Use WebExtension to run content javascript in tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/03f9dfc360de
Use .equals instead of == for GeckoSession. r=snorp
https://hg.mozilla.org/integration/autoland/rev/94a6bc1d5443
Add GeckoSessionTestRule.createFromParcel. r=snorp
https://hg.mozilla.org/integration/autoland/rev/67dbdef6e00a
Fix for ContentDelegateTest.autoFill_navigation. r=snorp
https://hg.mozilla.org/integration/autoland/rev/b03a8aee7acc
Use WebExtension to set prefs in tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/56f413baf041
Move getLinkColor to WebExtension. r=snorp
https://hg.mozilla.org/integration/autoland/rev/fa0cb607fe0d
Remove all remaining bits of RDP for tests. r=snorp
https://hg.mozilla.org/integration/autoland/rev/99faa668dfa0
Wait for link color in HistoryDelegateTest.getVisited. r=snorp
https://hg.mozilla.org/integration/autoland/rev/059dc56460e0
Re-enable geckoview-junit on x86_64. r=gbrown
https://hg.mozilla.org/integration/autoland/rev/cabf177300f4
Always send navigation events for about:blank. r=snorp
Depends on: 1560641
Depends on: 1564507

geckoview-junit now runs on x86_64 opt so we don't need to run the tests on arm
too.

Depends on: 1564621
Regressions: 1545931
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8c3c0710eb53
Don't run geckoview-junit on arm opt. r=gbrown
Duplicate of this bug: 1521195

I'm editing a bunch of GeckoView bugs. If you'd like to filter all this bugmail, search and destroy emails containing this UUID:

e88a5094-0fc0-4b7c-b7c5-aef00a11dbc9

Priority: P1 → P2
Depends on: 1419461
No longer depends on: 1419461
Attachment #9084960 - Attachment description: Bug 1553515 - Enable gv-test on x86_64. → Bug 1553515 - Enable gv-test on debug x86_64.
Attachment #9084960 - Attachment description: Bug 1553515 - Enable gv-test on debug x86_64. → Bug 1553515 - Enable geckoview-test on debug x86_64.

This is the last patch in this bug \o/

Keywords: leave-open
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0a70ad667f71
Enable geckoview-test on debug x86_64. r=snorp
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

69=wontfix because we don't want to uplift all these test changes to Beta.

You need to log in before you can comment on or make changes to this bug.