Nightly only restores partial session after updating

RESOLVED FIXED in Firefox 69

Status

()

defect
P2
normal
RESOLVED FIXED
3 months ago
23 days ago

People

(Reporter: dennis, Assigned: mikedeboer)

Tracking

(Blocks 1 bug)

68 Branch
Firefox 69
Points:
5
Dependency tree / graph

Firefox Tracking Flags

(firefox67 wontfix, firefox68 wontfix, firefox69 fixed)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

For a few weeks the following scenario has been happening roughly every third time I am notified of a new Nightly update:

  • Received a notification that a new Nightly version is available
  • Restarted via that notification

Actual results:

  • Nightly closed, installed updates and restarted
  • Only one of my several pinned tabs and no unpinned tab was restored

Expected results:

  • All previous tabs should have been restored

Manually closing and relaunching Nightly I'm unable to reproduce the problem. It's only ever happened when restarting with pending updates.

Component: Untriaged → Session Restore

Same here - 68.0a1 (2019-04-23) (64-bit) on Gentoo Linux.

Same here - 68.0a1 (2019-04-29) (64-Bit) on Windows 10.

With the information provided here, there's no way to reproduce the issue and therewith determine if this is a session restore issue or anything else. Provided that this issue has not been reported for Beta, I'm marking this as a P4 for now.
If anyone who experiences this can provide more details, like about:support contents, Browser Console logs, etc, would be much appreciated!

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dennis)
Priority: -- → P4

Mike,

I'm attaching about:support data from an affected profile. As the issue is intermittent, it's really hard to pin down but it has occurred with a new-ish profile as well (new profile, ublock origin as the only extension) after a couple of days of use.

While I have not seen this issue for a week, my coworker Daniel from comment 2 has seen this since about the same time as me but a lot more frequently, recently.

The browser console didn't show anything remarkable when the problem last occurred for me but we'll make sure to attach logs once it happens again.

Is there anything else we might save that would help with getting to the bottom of this?

Flags: needinfo?(dennis)

(In reply to Mike de Boer [:mikedeboer] from comment #3)

With the information provided here, there's no way to reproduce the issue and therewith determine if this is a session restore issue or anything else. Provided that this issue has not been reported for Beta, I'm marking this as a P4 for now.
If anyone who experiences this can provide more details, like about:support contents, Browser Console logs, etc, would be much appreciated!

Browser-Konsole:

Unkown category for SetEventRecordingEnabled.
No messages returned from https://snippets.cdn.mozilla.net/6/Firefox/68.0a1/20190430121130/WINNT_x86_64-msvc/de/nightly/Windows_NT%2010.0/default/default/. ASRouter.jsm:56
Error: listener not re-registered 2 ExtensionCommon.jsm:2129:22
Synchrone XMLHttpRequests am Haupt-Thread sollte nicht mehr verwendet werden, weil es nachteilige Effekte für das Erlebnis der Endbenutzer hat. Für weitere Hilfe siehe http://xhr.spec.whatwg.org/ background.js:139:12
listener not re-registered 2 ExtensionCommon.jsm:2129
Tastenereignis ist in manchen Tastaturlayouts nicht verfügbar: Taste="i" Modifikatoren="accel,alt,shift" ID=“key_browserToolbox” browser.xul
Image corrupt or truncated. downloadNative.aspx
Image corrupt or truncated. xn--allestrungen-9ib.de
Image corrupt or truncated. services
Image corrupt or truncated. duckduckgo.com
Image corrupt or truncated. postdownload
Image corrupt or truncated. duckduckgo.com
Image corrupt or truncated. duckduckgo.com
Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting. 2 Troubleshoot.jsm:510:25
Error: WebGL warning: <SetDimensions>: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR Troubleshoot.jsm:510:25
Error: WebGL warning: <SetDimensions>: Failed to create WebGL context: WebGL creation failed:

  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR Troubleshoot.jsm:510:25
    [fluent] Missing translations in en-US: vbox-disp-d3-d. Localization.jsm:202:13
    Log warning: The log 'Services.Common.RESTRequest' is configured to use the preference 'services.common.log.logger.rest.request' - you must adjust the level by setting this preference, not by using the level setter Log.jsm:20
    Discarding onCreatedNavigationTarget for 14: received source tab data without any created tab data available
    1556777673946 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556777673948 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556777673960 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    asyncloadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    UP__showUI@UpdateService.jsm:4951:19
    UP_showUpdateHistory@UpdateService.jsm:4765:10
    setupEventListeners/<@aboutSupport.js:1227:16
    EventListener.handleEvent
    setupEventListeners@aboutSupport.js:1225:12
    onload@aboutSupport.js:25:5
    EventListener.handleEvent*@aboutSupport.js:17:8
    Content Security Policy: Die Direktive 'child-src' sollte nicht mehr verwendet werden. Bitte verwenden Sie stattdessen die Direktive 'worker-src' zum Kontrollieren von Workern bzw. die Direktive 'frame-src' zum Kontrollieren von Frames.
    [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowUtils.removeSheet]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource://gre/modules/ExtensionCommon.jsm :: runSafeSyncWithoutClone :: line 65" data: no] 2 ExtensionCommon.jsm:65:12
    1556777710593 Toolkit.Telemetry WARN TelemetryStorage::_scanArchive - have seen this id before: b39b9210-17da-4705-90fa-b29b2c240c3d, overwrite: false
    1556777768155 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556777768162 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556777768170 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    async*loadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    Error: WebGL warning: getContext: Disallowing antialiased backbuffers due to blacklisting. 2 Troubleshoot.jsm:510:25
    Error: WebGL warning: <SetDimensions>: Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR Troubleshoot.jsm:510:25
    Error: WebGL warning: <SetDimensions>: Failed to create WebGL context: WebGL creation failed:
  • Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR Troubleshoot.jsm:510:25
    1556778373130 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556778373137 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556778373144 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    asyncloadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    nsLoginManager: searchLogins: formSubmitURL or httpRealm is recommended LoginManager.jsm:406:13
    Invalid chrome URI: /
    [Exception... "Favicon at "https://192.168.14.10/favicon.ico" failed to load: Not Found." nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 199" data: no] FaviconLoader.jsm:199:42
    XML-Verarbeitungsfehler: nicht wohlgeformt
    Adresse: https://192.168.14.10/api/mgt/1.0/login
    Zeile Nr. 1, Spalte 1: login:1:1
    1556778977901 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556778977916 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556778977925 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    async
    loadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    1556779583191 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556779583195 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556779583201 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    asyncloadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    Eine Notification-Anfrage kann nur in einem sicheren Kontext gestartet werden. stoerungsmeldungen.tannenhof.intern
    1556780188737 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556780188746 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556780188755 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    async
    loadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    1556780192203 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556780192208 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556780192227 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    asyncloadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    XML-Verarbeitungsfehler: nicht wohlgeformt
    Adresse: https://192.168.14.10/api/mgt/1.0/refresh-token
    Zeile Nr. 1, Spalte 1: refresh-token:1:1
    1556780798173 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556780798185 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556780798194 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    async
    loadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    XML-Verarbeitungsfehler: nicht wohlgeformt
    Adresse: https://192.168.14.10/api/mgt/1.0/refresh-token
    Zeile Nr. 1, Spalte 1: refresh-token:1:1
    1556781403177 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556781403187 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556781403196 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    asyncloadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    XML-Verarbeitungsfehler: nicht wohlgeformt
    Adresse: https://192.168.14.10/api/mgt/1.0/refresh-token
    Zeile Nr. 1, Spalte 1: 3 refresh-token:1:1
    1556783986469 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing background.persistent: Event pages are not currently supported. This will run as a persistent background page.
    1556783986473 addons.webextension.<unknown> WARN Loading extension 'null': Reading manifest: Error processing update_url: An unexpected property was found in the WebExtension manifest.
    1556783986493 addons.xpi WARN Download of https://addons.mozilla.org/firefox/downloads/file/1673901/tel_linker-0.5.3-fx.xpi?src=sync failed: Error: Extension is signed with an invalid id (ab7765828f4fee6dfa3558c5a01b9ab9975ea3c8c446e487bb879b957675cde5)(resource://gre/modules/addons/XPIInstall.jsm:567:15) JS Stack trace: loadManifest@XPIInstall.jsm:567:15
    async
    loadManifest@XPIInstall.jsm:1321:28
    onStopRequest@XPIInstall.jsm:2114:14
    [2019-05-02T08:04:17.516Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/qh3at8orzjc0orget93zjdsmg55pyisv/httpsscan background.js:34:17
    [2019-05-02T08:04:17.584Z] Request status: 2 background.js:34:17
    [2019-05-02T08:04:17.585Z] Request status: 3 background.js:34:17
    [2019-05-02T08:04:17.585Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:17
    [2019-05-02T08:04:17.585Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:17
    [2019-05-02T08:04:47.522Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/qh3at8orzjc0orget93zjdsmg55pyisv/httpsscan background.js:34:17
    [2019-05-02T08:04:47.549Z] Request status: 2 background.js:34:17
    [2019-05-02T08:04:47.550Z] Request status: 3 background.js:34:17
    [2019-05-02T08:04:47.551Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:17
    [2019-05-02T08:04:47.552Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:17
    [2019-05-02T08:05:17.535Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/qh3at8orzjc0orget93zjdsmg55pyisv/httpsscan background.js:34:17
    [2019-05-02T08:05:17.553Z] Request status: 2 background.js:34:17
    [2019-05-02T08:05:17.555Z] Request status: 3 background.js:34:17
    [2019-05-02T08:05:17.556Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:17
    [2019-05-02T08:05:17.556Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:17
    [2019-05-02T08:05:47.565Z] Sending {"url":"http://native_channel","referer":"http://native_channel","rqtype":5} to: http://localhost:44117/qh3at8orzjc0orget93zjdsmg55pyisv/httpsscan background.js:34:17
    [2019-05-02T08:05:47.578Z] Request status: 2 background.js:34:17
    [2019-05-02T08:05:47.579Z] Request status: 3 background.js:34:17
    [2019-05-02T08:05:47.579Z] Response: { "native_channel": { "safesearch_enabled": false } } background.js:34:17
    [2019-05-02T08:05:47.580Z] native_channel response: {"native_channel":{"safesearch_enabled":false}} background.js:37:17

(In reply to Mike de Boer [:mikedeboer] from comment #3)

With the information provided here, there's no way to reproduce the issue and therewith determine if this is a session restore issue or anything else. Provided that this issue has not been reported for Beta, I'm marking this as a P4 for now.
If anyone who experiences this can provide more details, like about:support contents, Browser Console logs, etc, would be much appreciated!

About:support

{
"application": {
"name": "Firefox",
"osVersion": "Windows_NT 10.0",
"version": "68.0a1",
"buildID": "20190430121130",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0",
"safeMode": false,
"updateChannel": "nightly",
"supportURL": "https://support.mozilla.org/1/firefox/68.0a1/WINNT/de/",
"numTotalWindows": 1,
"numRemoteWindows": 1,
"launcherProcessState": 0,
"remoteAutoStart": true,
"autoStartStatus": 1,
"policiesStatus": 0,
"keyLocationServiceGoogleFound": true,
"keySafebrowsingGoogleFound": true,
"keyMozillaFound": true
},
"securitySoftware": {
"registeredAntiVirus": "F-Secure Client Security",
"registeredAntiSpyware": "F-Secure Client Security",
"registeredFirewall": "Windows-Firewall"
},
"processes": {
"remoteTypes": {
"web": 3,
"privileged": 1,
"extension": 1,
"gpu": 1
},
"maxWebContentProcesses": 8
},
"modifiedPreferences": {
"accessibility.typeaheadfind": true,
"accessibility.typeaheadfind.flashBar": 0,
"browser.cache.disk.amount_written": 606602,
"browser.cache.disk.capacity": 1048576,
"browser.cache.disk.filesystem_reported": 1,
"browser.cache.disk.hashstats_reported": 1,
"browser.download.useDownloadDir": false,
"browser.sessionstore.upgradeBackup.latestBuildID": "20190429215338",
"browser.startup.homepage": "http://www.google.de/",
"browser.startup.homepage_override.buildID": "20190430121130",
"browser.startup.homepage_override.mstone": "68.0a1",
"browser.tabs.loadInBackground": false,
"browser.urlbar.matchBuckets": "general:5,suggestion:Infinity",
"browser.urlbar.maxRichResults": 12,
"browser.urlbar.placeholderName": "Google",
"browser.urlbar.timesBeforeHidingSuggestionsHint": 0,
"dom.forms.autocomplete.formautofill": true,
"dom.push.userAgentID": "55ecfcaca66a4fa7927cabcffa7ff9c8",
"extensions.lastAppVersion": "68.0a1",
"idle.lastDailyNotification": 1556694696,
"layers.mlgpu.sanity-test-failed": false,
"media.gmp-manager.lastCheck": 1556778074,
"media.gmp-manager.buildID": "20190430121130",
"media.gmp-gmpopenh264.abi": "x86_64-msvc-x64",
"media.gmp-gmpopenh264.lastUpdate": 1553258646,
"media.gmp-gmpopenh264.version": "1.8.1",
"media.gmp-widevinecdm.abi": "x86_64-msvc-x64",
"media.gmp-widevinecdm.lastUpdate": 1553258649,
"media.gmp-widevinecdm.version": "4.10.1146.0",
"media.gmp.storage.version.observed": 1,
"media.hardware-video-decoding.failed": false,
"network.dns.disablePrefetch": true,
"network.http.speculative-parallel-limit": 0,
"network.predictor.enabled": false,
"network.prefetch-next": false,
"places.history.expiration.transient_current_max_pages": 153901,
"places.database.lastMaintenance": 1556608301,
"plugin.disable_full_page_plugin_for_types": "application/pdf",
"privacy.sanitize.pending": "[{"id":"newtab-container","itemsToClear":[],"options":{}}]",
"privacy.clearOnShutdown.passwords": false,
"privacy.donottrackheader.enabled": true,
"security.remote_settings.intermediates.checked": 1556608163,
"security.sandbox.content.tempDirSuffix": "{046340cf-0590-4058-a73a-26405d4f763f}",
"security.sandbox.plugin.tempDirSuffix": "{9d1116f2-bd62-40cb-8469-e4a2cdf45386}",
"services.sync.declinedEngines": "",
"services.sync.lastPing": 1556711790,
"services.sync.lastSync": "Thu May 02 2019 08:16:09 GMT+0200 (Mitteleuropäische Sommerzeit)",
"services.sync.engine.addresses": true,
"services.sync.engine.addresses.available": true,
"services.sync.engine.bookmarks.validation.lastTime": 1556711793,
"services.sync.engine.passwords.validation.lastTime": 1556711793,
"services.sync.engine.prefs.modified": false,
"signon.importedFromSqlite": true,
"storage.vacuum.last.index": 1,
"storage.vacuum.last.places.sqlite": 1556608297,
"ui.osk.debug.keyboardDisplayReason": "IKPOS: Touch screen not found."
},
"lockedPreferences": {},
"media": {
"currentAudioBackend": "wasapi",
"currentMaxAudioChannels": 6,
"currentPreferredSampleRate": 44100,
"audioOutputDevices": [
{
"name": "Lautsprecher (High Definition Audio-Gerät)",
"groupId": "HDAUDIO\FUNC_01&VEN_8384&DEV_7680&SUBSYS_83847680&REV_1034\4&31e60982&0&0001",
"vendor": "",
"type": 2,
"state": 2,
"preferred": 7,
"supportedFormat": 4112,
"defaultFormat": 4096,
"maxChannels": 6,
"defaultRate": 44100,
"maxRate": 44100,
"minRate": 44100,
"maxLatency": 448,
"minLatency": 129
},
{
"name": "Kopfhörer (High Definition Audio-Gerät)",
"groupId": "HDAUDIO\FUNC_01&VEN_8384&DEV_7680&SUBSYS_83847680&REV_1034\4&31e60982&0&0001",
"vendor": "",
"type": 2,
"state": 1,
"preferred": 0,
"supportedFormat": 4112,
"defaultFormat": 4096,
"maxChannels": 0,
"defaultRate": 0,
"maxRate": 0,
"minRate": 0,
"maxLatency": 0,
"minLatency": 0
}
],
"audioInputDevices": [
{
"name": "Interne AUX-Buchse (High Definition Audio-Gerät)",
"groupId": "HDAUDIO\FUNC_01&VEN_8384&DEV_7680&SUBSYS_83847680&REV_1034\4&31e60982&0&0001",
"vendor": "",
"type": 1,
"state": 0,
"preferred": 0,
"supportedFormat": 4112,
"defaultFormat": 4096,
"maxChannels": 0,
"defaultRate": 0,
"maxRate": 0,
"minRate": 0,
"maxLatency": 0,
"minLatency": 0
},
{
"name": "Mikrofon (High Definition Audio-Gerät)",
"groupId": "HDAUDIO\FUNC_01&VEN_8384&DEV_7680&SUBSYS_83847680&REV_1034\4&31e60982&0&0001",
"vendor": "",
"type": 1,
"state": 2,
"preferred": 7,
"supportedFormat": 4112,
"defaultFormat": 4096,
"maxChannels": 2,
"defaultRate": 44100,
"maxRate": 44100,
"minRate": 44100,
"maxLatency": 448,
"minLatency": 129
}
]
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0,
"handlerUsed": true,
"instantiator": ""
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.21",
"version": "4.21"
},
"NSS": {
"minVersion": "3.44 Beta",
"version": "3.44 Beta"
},
"NSSUTIL": {
"minVersion": "3.44 Beta",
"version": "3.44 Beta"
},
"NSSSSL": {
"minVersion": "3.44 Beta",
"version": "3.44 Beta"
},
"NSSSMIME": {
"minVersion": "3.44 Beta",
"version": "3.44 Beta"
}
},
"userJS": {
"exists": false
},
"intl": {
"localeService": {
"requested": [
"de"
],
"available": [
"de",
"en-US"
],
"supported": [
"de",
"en-US"
],
"regionalPrefs": [
"de-DE"
],
"defaultLocale": "de"
},
"osPrefs": {
"systemLocales": [
"de-DE"
],
"regionalPrefsLocales": [
"de-DE"
]
}
},
"crashes": {
"submitted": [],
"pending": 0
},
"sandbox": {
"contentSandboxLevel": 5,
"effectiveContentSandboxLevel": 5
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 0,
"windowLayerManagerType": "Basic",
"windowLayerManagerRemote": true,
"windowUsingAdvancedLayers": false,
"numAcceleratedWindowsMessage": {
"key": "blocked-gfx-card"
},
"adapterDescription": "VirtualBox Graphics Adapter (WDDM)",
"adapterVendorID": "0x80ee",
"adapterDeviceID": "0xbeef",
"adapterSubsysID": "040515ad",
"adapterRAM": "0",
"adapterDrivers": "VBoxDispD3D",
"driverVersion": "6.0.4.0",
"driverDate": "1-25-2019",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterSubsysID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": false,
"directWriteEnabled": true,
"directWriteVersion": "10.0.17763.168",
"clearTypeParameters": "Gamma: 1,8 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ",
"usesTiling": false,
"contentUsesTiling": true,
"offMainThreadPaintEnabled": true,
"offMainThreadPaintWorkerCount": 3,
"targetFrameRate": 64,
"direct2DEnabledMessage": {
"key": "blocked-gfx-card"
},
"webgl1Renderer": "Google Inc. -- ANGLE (Microsoft Basic Render Driver Direct3D11 vs_5_0 ps_5_0)",
"webgl1Version": "OpenGL ES 2.0 (ANGLE 2.1.0.11fe1e4ce42b)",
"webgl1DriverExtensions": "GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_explicit_context GL_ANGLE_explicit_context_gles1 GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_memory_size GL_ANGLE_multi_draw GL_ANGLE_multiview_multisample GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_provoking_vertex GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_float_blend GL_EXT_frag_depth GL_EXT_instanced_arrays GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_bptc GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_KHR_parallel_shader_compile GL_KHR_robust_buffer_access_behavior GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_border_clamp GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object OES_compressed_EAC_R11_signed_texture OES_compressed_EAC_R11_unsigned_texture OES_compressed_EAC_RG11_signed_texture OES_compressed_EAC_RG11_unsigned_texture OES_compressed_ETC2_RGB8_texture OES_compressed_ETC2_RGBA8_texture OES_compressed_ETC2_punchthroughA_RGBA8_texture OES_compressed_ETC2_punchthroughA_sRGB8_alpha_texture OES_compressed_ETC2_sRGB8_alpha8_texture OES_compressed_ETC2_sRGB8_texture ",
"webgl1Extensions": "ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_disjoint_timer_query EXT_float_blend EXT_frag_depth EXT_shader_texture_lod EXT_sRGB EXT_texture_compression_bptc EXT_texture_filter_anisotropic OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context",
"webgl1WSIInfo": "EGL_VENDOR: Google Inc. (adapter LUID: 000000000000494b)\nEGL_VERSION: 1.4 (ANGLE 2.1.0.11fe1e4ce42b)\nEGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_ANGLE_create_context_extensions_enabled EGL_ANDROID_blob_cache EGL_ANDROID_recordable \nEGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_KHR_debug EGL_ANGLE_explicit_context ",
"webgl2Renderer": "WebGL creation failed: \n* Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR",
"webgl2Version": "-",
"webgl2DriverExtensions": "-",
"webgl2Extensions": "-",
"webgl2WSIInfo": "-",
"info": {
"AzureCanvasBackend (UI Process)": "skia",
"AzureFallbackCanvasBackend (UI Process)": "cairo",
"AzureContentBackend (UI Process)": "skia",
"AzureCanvasBackend": "skia",
"AzureContentBackend": "skia",
"ApzWheelInput": 1,
"ApzDragInput": 1,
"ApzKeyboardInput": 1,
"ApzAutoscrollInput": 1
},
"featureLog": {
"features": [
{
"name": "HW_COMPOSITING",
"description": "Compositing",
"status": "available",
"log": [
{
"type": "default",
"status": "available"
}
]
},
{
"name": "D3D11_COMPOSITING",
"description": "Direct3D11 Compositing",
"status": "blacklisted",
"log": [
{
"type": "default",
"status": "available"
},
{
"type": "env",
"status": "blacklisted",
"message": "#BLOCKLIST_FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR"
}
]
},
{
"name": "DIRECT2D",
"description": "Direct2D",
"status": "unavailable",
"log": [
{
"type": "default",
"status": "unavailable",
"message": "Direct2D requires Direct3D 11 compositing"
}
]
},
{
"name": "D3D11_HW_ANGLE",
"description": "Direct3D11 hardware ANGLE",
"status": "disabled",
"log": [
{
"type": "default",
"status": "unavailable",
"message": "D3D11 compositing is disabled"
},
{
"type": "env",
"status": "disabled",
"message": "D3D11 compositing is disabled"
}
]
},
{
"name": "GPU_PROCESS",
"description": "GPU Process",
"status": "available",
"log": [
{
"type": "default",
"status": "available"
}
]
},
{
"name": "WEBRENDER",
"description": "WebRender",
"status": "unavailable",
"log": [
{
"type": "default",
"status": "opt-in",
"message": "WebRender is an opt-in feature"
},
{
"type": "runtime",
"status": "unavailable",
"message": "ANGLE is disabled"
}
]
},
{
"name": "WEBRENDER_QUALIFIED",
"description": "WebRender qualified",
"status": "blocked",
"log": [
{
"type": "default",
"status": "available"
},
{
"type": "env",
"status": "blocked",
"message": "No qualified hardware"
}
]
},
{
"name": "OMTP",
"description": "Off Main Thread Painting",
"status": "available",
"log": [
{
"type": "default",
"status": "available"
}
]
}
],
"fallbacks": []
},
"crashGuards": []
},
"extensions": [
{
"name": "Amazon.de",
"version": "1.0",
"isActive": true,
"id": "amazondotcom@search.mozilla.org"
},
{
"name": "Bing",
"version": "1.0",
"isActive": true,
"id": "bing@search.mozilla.org"
},
{
"name": "Browsing Protection by F-Secure",
"version": "2.220.7818",
"isActive": true,
"id": "ols@f-secure.com"
},
{
"name": "DuckDuckGo",
"version": "1.0",
"isActive": true,
"id": "ddg@search.mozilla.org"
},
{
"name": "eBay",
"version": "1.0",
"isActive": true,
"id": "ebay@search.mozilla.org"
},
{
"name": "Ecosia",
"version": "1.0",
"isActive": true,
"id": "ecosia@search.mozilla.org"
},
{
"name": "Google",
"version": "1.0",
"isActive": true,
"id": "google@search.mozilla.org"
},
{
"name": "LEO Eng-Deu",
"version": "1.0",
"isActive": true,
"id": "leo_ende_de@search.mozilla.org"
},
{
"name": "uBlock Origin",
"version": "1.18.16",
"isActive": true,
"id": "uBlock0@raymondhill.net"
},
{
"name": "Wikipedia (de)",
"version": "1.0",
"isActive": true,
"id": "wikipedia@search.mozilla.org"
}
],
"features": [
{
"name": "Firefox Monitor",
"version": "3.0",
"id": "fxmonitor@mozilla.org"
},
{
"name": "Firefox Screenshots",
"version": "37.1.0",
"id": "screenshots@mozilla.org"
},
{
"name": "Form Autofill",
"version": "1.0",
"id": "formautofill@mozilla.org"
},
{
"name": "Web Compat",
"version": "4.2.0",
"id": "webcompat@mozilla.org"
},
{
"name": "WebCompat Reporter",
"version": "1.1.0",
"id": "webcompat-reporter@mozilla.org"
}
]
}

Duplicate of this bug: 1536800

Thanks, Daniel, for the information you supplied ;-) Perhaps next time you can attach the information as plain text files to the bug, which would avoid the lengthy comments.

I'm going to make a behavior change to SessionStore to ignore (shutdown) crashes on update/ automated restart or when restoring a session on startup is set as the default.

We check whether the previous session crashed, but we don't analyze further if it happened to be a shutdown crash - which is apparently quite common on Nightly, lately.

Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 68.4 - Apr 29 - May 12
Points: --- → 5
Priority: P4 → P2

I also made a few gratuitous code formatting cleanups. I hope you don't mind.
We are unable to properly analyze shutdown crashes and deduce the right action
to take when that happened. This leads to surprising occurrences of the
'about:sessionrestore' page shown, especially when a full restore is expected
anyway.

Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b821fc0de45c
When a session is set to resume anyways, skip analyzing previous crashes and always restore immediately. r=dao
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce950f1fe559
When a session is set to resume anyways, skip analyzing previous crashes and always restore immediately. r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69

P2, just landed in 69 and not a minimal patch, it doesn't feel like something we would uplift to release, so marking as wontfix for 67. In case you have a case for uplifting to release, please reach out to me or :lizzard, thanks.

Flags: needinfo?(mdeboer)

Is this worth uplifting to beta?

Flags: needinfo?(mdeboer)
Regressed by: 1554076
No longer regressed by: 1554076
Regressions: 1554076

(In reply to Pascal Chevrel:pascalc (PTO until June 2) from comment #17)

P2, just landed in 69 and not a minimal patch, it doesn't feel like something we would uplift to release, so marking as wontfix for 67. In case you have a case for uplifting to release, please reach out to me or :lizzard, thanks.

Well, the issue is serious and affects Firefox 67, too. The risk is having incredibly frustrated users who would find themselves with their sessions completely wiped out (such as myself), in some cases with hundreds of tabs. The case is simple in my eyes: this is not a trivial bug one can forget about, but one that has had a serious impact over the usage of Firefox ever since the release of 67, with every new update coming out that completely nukes my sessions and requires manual intervention to restore the session (by copying the old sessionstore-backups/previous.jsonlz4 file to sessionstore.jsonlz4), although this always leads to lost content - in some cases important content that there's no way to retrieve.
Thank you for your attention and your work!

Regressions: 1557619

Ping timeout, let's let this ride the trains.

Flags: needinfo?(mdeboer)
You need to log in before you can comment on or make changes to this bug.