Closed Bug 1543696 Opened 2 years ago Closed 1 year ago

Perma toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Color property should be unset - Got rgb(255, 0, 255), expected when Gecko 68 merges to Beta on 2019-05-06

Categories

(WebExtensions :: General, defect, P2)

defect

Tracking

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

VERIFIED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + verified

People

(Reporter: intermittent-bug-filer, Assigned: ntim)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(2 files)

#[markdown(off)]
Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=239665536&repo=try

https://queue.taskcluster.net/v1/task/SSN-T6OWTWiPpBcxbTRBbg/runs/0/artifacts/public/logs/live_backing.log

13:30:21 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Generic Property should be unset. -
13:30:21 INFO - Testing that current window updated with the experiment applied
13:30:21 INFO - Buffered messages finished
13:30:21 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Color property should be unset - Got rgb(255, 0, 255), expected
13:30:21 INFO - Stack trace:
13:30:21 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
13:30:21 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:testExperimentApplied:61
13:30:21 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:test_experiment_static_theme:71
13:30:21 INFO - Not taking screenshot here: see the one that was previously logged
13:30:21 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Image property should be unset - Got url(moz-extension://156a68f5-0ca5-485e-b23e-6b139f02946e/background.jpg), expected
13:30:21 INFO - Stack trace:
13:30:21 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
13:30:21 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:testExperimentApplied:63
13:30:21 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:test_experiment_static_theme:71
13:30:21 INFO - Not taking screenshot here: see the one that was previously logged
13:30:21 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Generic Property should be unset. - Got no-repeat, expected
13:30:21 INFO - Stack trace:
13:30:21 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
13:30:21 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:testExperimentApplied:65
13:30:21 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:test_experiment_static_theme:71
13:30:21 INFO - Testing that new window initialized with the experiment applied
13:30:21 INFO - GECKO(9260) | JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 162: Array.forEach is deprecated; use Array.prototype.forEach instead
13:30:21 INFO - Console message: [JavaScript Warning: "Array.forEach is deprecated; use Array.prototype.forEach instead" {file: "chrome://global/content/bindings/tabbox.xml" line: 162}]
13:30:21 INFO - GECKO(9260) | JavaScript warning: chrome://browser/content/browser-ctrlTab.js, line 568: Array.filter is deprecated; use Array.prototype.filter instead
13:30:22 INFO - Not taking screenshot here: see the one that was previously logged
13:30:22 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Color property should be unset - Got rgb(255, 0, 255), expected
13:30:22 INFO - Stack trace:
13:30:22 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
13:30:22 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:testExperimentApplied:61
13:30:22 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:test_experiment_static_theme:76
13:30:22 INFO - Not taking screenshot here: see the one that was previously logged
13:30:22 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Image property should be unset - Got url(moz-extension://156a68f5-0ca5-485e-b23e-6b139f02946e/background.jpg), expected
13:30:22 INFO - Stack trace:
13:30:22 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
13:30:22 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:testExperimentApplied:63
13:30:22 INFO - chrome://mochitests/content/browser/toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js:test_experiment_static_theme:76
13:30:22 INFO - Not taking screenshot here: see the one that was previously logged

Summary: Intermittent toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Color property should be unset - Got rgb(255, 0, 255), expected when Gecko 68 merges to Beta on 2019-05-06 → Perma toolkit/components/extensions/test/browser/browser_ext_themes_experiment.js | Color property should be unset - Got rgb(255, 0, 255), expected when Gecko 68 merges to Beta on 2019-05-06
Flags: needinfo?(ntim.bugs)

Changing the priority to p2 as the bug is tracked by a release manager for the current nightly.
See How Do You Triage for more information

Priority: P5 → P2
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7f0e02401370
Don't set extensions.legacy.enabled on beta in browser_ext_themes_experiment.js. r=kmag

Backed out changeset 7f0e02401370 (bug 1543696) for browser-chrome failures at toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js

Backout: https://hg.mozilla.org/integration/autoland/rev/7dad55e9bd2bd60ea5462c2cfa1281a82aa0a4b6

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=7f0e024013704d89e01b6f8103fbfd6ef5f0107b

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=240123700&repo=autoland&lineNumber=6496

09:57:19 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/Unrecognized theme property found: properties.unknown_property/}] -
09:57:19 INFO - Testing that experiments are handled correctly when legacy pref is disabled
09:57:19 INFO - Extension loaded
09:57:19 INFO - Console message: Warning: attempting to write 7479 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
09:57:19 INFO - Console message: SENTINEL
09:57:19 INFO - Buffered messages finished
09:57:19 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/This extension is not allowed to run theme experiments/}] - got +0, expected 1
09:57:19 INFO - Stack trace:
09:57:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.is:320
09:57:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:listener:1323
09:57:19 INFO - chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:observe/<:377
09:57:19 INFO - Leaving test bound test_experiment
09:57:19 INFO - GECKO(2373) | MEMORY STAT | vsize 5549MB | residentFast 413MB | heapAllocated 183MB

Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1ee98a3cd8fb
Don't set extensions.legacy.enabled on beta in browser_ext_themes_experiment.js. r=kmag
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cade5cf8a0ed
Don't set extensions.legacy.enabled on beta in browser_ext_themes_experiment.js. r=kmag

Backed out changeset cade5cf8a0ed (bug 1543696) for browser-chrome at toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js

Backout: https://hg.mozilla.org/integration/autoland/rev/b60534ec20b8bc628b691d72f4c3100b4f31b97f

Failure push: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=240129224&revision=cade5cf8a0ed653fae2b81f9de8219df426a847c

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=240133944&repo=autoland&lineNumber=6493

11:46:36 INFO - TEST-PASS | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/Unrecognized theme property found: properties.unknown_property/}] -
11:46:36 INFO - Testing that experiments are handled correctly when legacy pref is disabled
11:46:36 INFO - Extension loaded
11:46:36 INFO - Console message: Warning: attempting to write 7479 bytes to preference extensions.webextensions.uuids. This is bad for general performance and memory usage. Such an amount of data should rather be written to an external file. This preference will not be sent to any content processes.
11:46:36 INFO - Console message: SENTINEL
11:46:36 INFO - Buffered messages finished
11:46:36 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | monitorConsole | number of messages [{message:/This extension is not allowed to run theme experiments/}] - got +0, expected 1
11:46:36 INFO - Stack trace:
11:46:36 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.is:320
11:46:36 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:listener:1323
11:46:36 INFO - chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:observe/<:377
11:46:36 INFO - Leaving test bound test_experiment
11:46:36 INFO - GECKO(1227) | MEMORY STAT | vsize 5549MB | residentFast 388MB | heapAllocated 135MB
11:46:36 INFO - TEST-OK | toolkit/components/extensions/test/browser/browser_ext_themes_warnings.js | took 1052ms
11:46:36 INFO - checking window state
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1232
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1229
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1233
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1235
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1234
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1236
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1230
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1237
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1228
11:46:38 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1231
11:46:39 INFO - GECKO(1227) | Completed ShutdownLeaks collections in process 1227

Flags: needinfo?(ntim.bugs)
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bdd3825511f3
Don't set extensions.legacy.enabled on beta in browser_ext_themes_experiment.js. r=kmag
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)

How is the latest version of the patch ?

Flags: needinfo?(ntim.bugs) → needinfo?(nerli)
Flags: needinfo?(nerli)

(In reply to Noemi Erli[:noemi_erli] from comment #17)

I tried the latest patch here: https://hg.mozilla.org/try/rev/008019ed9eb7a436b65e04bba91a5d42c35fd11b

Note that this is not the latest patch, the latest patch has a cleanup() function.

Flags: needinfo?(nerli)

Tim, we were just waiting for the test results before posting it.

(In reply to Tim Nguyen :ntim from comment #19)

Looks like this was done here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=badfe285e2a1047dab68909ba39683ffd0f180ab

Hmm, looks like the failure is still there :/

Flags: needinfo?(ntim.bugs)
Duplicate of this bug: 1545943
Attachment #9059464 - Attachment description: Bug 1543696 - Set extensions.legacy.enabled to false on beta in browser_ext_themes_experiment.js. r=kmag → Bug 1543696 - Fix browser_ext_themes_experiment.js and browser_ext_themes_warnings.js failures due extensions.legacy.enabled behaving differently on automation. r=kmag
Attachment #9059464 - Attachment description: Bug 1543696 - Fix browser_ext_themes_experiment.js and browser_ext_themes_warnings.js failures due extensions.legacy.enabled behaving differently on automation. r=kmag → Bug 1543696 - Fix browser_ext_themes_experiment.js and browser_ext_themes_warnings.js failures due to extensions.legacy.enabled behaving differently on automation. r=kmag
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/352f3ef0d7df
Fix browser_ext_themes_experiment.js and browser_ext_themes_warnings.js failures due to extensions.legacy.enabled behaving differently on automation. r=kmag
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.