Closed Bug 1543961 Opened 6 months ago Closed 6 months ago

tweak iGC slices to be handled more often in case there is idle time

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: smaug, Assigned: smaug)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

No description provided.

The patch will make us use repeating IdleTaskRunner, not the single firing one.

Let's see what try thinks about it.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=bf7c1173679a674054f2b19649c7b1601e99c246

Priority: -- → P2
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2e9b1056dca8
tweak iGC slices to be handled more often in case there is idle time, r=jonco
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Hi Olli

There are some GC telemetry alerts (they're positive/benign) probably caused by this bug. What do you think?

https://mail.mozilla.org/private/dev-telemetry-gc-alerts/2019-April/thread.html

Flags: needinfo?(bugs)

I don't have access to that, but I was looking at telemetry data and so far haven't found anything unexpected.

Flags: needinfo?(bugs)
Blocks: 1547950
You need to log in before you can comment on or make changes to this bug.