The secondary pane should not open when paused

RESOLVED FIXED in Firefox 68

Status

enhancement
RESOLVED FIXED
3 months ago
9 days ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

(Blocks 3 bugs)

unspecified
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Last year we changed the debugger behavior to re-open the secondary pane when paused.

We did this because it is nice to see the call stack. The unintended consequence is when devtools is docked to the right or to the bottom and narrow, the UI can often be cramped. It is frustrating to close the secondary pane and then see it re-open.

Another thing that changed recently is that the command bar buttons are now visible even when the secondary pane is closed, which makes the pane less necessary.

Type: defect → enhancement
Blocks: 1544474
Regressions: 1544474
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f057b78337e7
The secondary pane should not open when paused. r=davidwalsh

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&revision=f057b78337e7442427b3379537c67d5761f2bf39&selectedJob=240393765&searchStr=linux%2Cx64%2Copt%2Cnode%2Ctests%2Csource-test-node-debugger-tests%2Cnode%28debugger%29

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=240393765&repo=autoland&lineNumber=801

Backout link: https://hg.mozilla.org/integration/autoland/rev/9c2a65500d3aebbc471d88d5f38676c7433ddb60

[task 2019-04-15T17:32:21.400Z] Error ------------------------------------------------------------------ src/utils/sources-tree/tests/utils.spec.js:51:9
[task 2019-04-15T17:32:21.401Z]
[task 2019-04-15T17:32:21.401Z] Cannot call addToTree because no more than 3 arguments are expected by function [1].
[task 2019-04-15T17:32:21.401Z]
[task 2019-04-15T17:32:21.401Z] src/utils/sources-tree/tests/utils.spec.js:51:9
[task 2019-04-15T17:32:21.401Z] 51| addToTree(tree, source, "http://example.com/", "")
[task 2019-04-15T17:32:21.401Z] ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
[task 2019-04-15T17:32:21.401Z]
[task 2019-04-15T17:32:21.402Z] References:
[task 2019-04-15T17:32:21.402Z] src/utils/sources-tree/addToTree.js:157:8
[task 2019-04-15T17:32:21.402Z] v------------------
[task 2019-04-15T17:32:21.402Z] 157| export function addToTree(
[task 2019-04-15T17:32:21.402Z] 158| tree: TreeDirectory,
[task 2019-04-15T17:32:21.402Z] 159| source: Source,
[task 2019-04-15T17:32:21.402Z] 160| debuggeeHost: ?string
[task 2019-04-15T17:32:21.402Z] 161| ) {
[task 2019-04-15T17:32:21.403Z] ^ [1]
[task 2019-04-15T17:32:21.403Z]
[task 2019-04-15T17:32:21.403Z]
[task 2019-04-15T17:32:21.403Z]
[task 2019-04-15T17:32:21.403Z] Found 25 errors

Flags: needinfo?(jlaster)
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b1d9126436b5
The secondary pane should not open when paused.
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → jlaster
Flags: needinfo?(jlaster)
Blocks: 1565711
Blocks: 1565713
You need to log in before you can comment on or make changes to this bug.