Change Fennec about:addons' AMO link title and URL

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
a month ago
29 days ago

People

(Reporter: cpeterson, Assigned: petru)

Tracking

(Regressed 1 bug)

unspecified
Firefox 68
Unspecified
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66- wontfix, firefox67 verified, firefox68 verified)

Details

(Whiteboard: [bcs:p1])

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

a month ago
  1. Change Fennec's about:addons's AMO link title to say "Browse recommended Firefox Add-ons" instead of "Browse all Firefox Add-ons". We will need to localize this new link title.

  2. Change Fennec's about:addons's AMO link to deep link to the list of featured Fennec extensions [1] instead of the generic AMO home page (which includes desktop extensions and themes that are not Fennec-compatible).

[1] https://addons.mozilla.org/android/search/?featured=true&type=extension

Reporter

Comment 1

a month ago

Devin, this is another Fennec bug we'd like Softvision to prioritize.

  1. The new AMO link title will need to be localized, so it might not be possible to uplift a fix to 67 Beta.

  2. The AMO link, OTOH, does not need to be localized so we could conceivably uplift it to 67 Beta or even a 66.0.x dot release.

Flags: needinfo?(dreams)
Assignee

Updated

a month ago
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Attachment #9058604 - Attachment description: Bug 1544525 - Update about:addons's AMO link and title; → Bug 1544525 - Update about:addons's AMO link and title
Assignee

Updated

a month ago
Keywords: checkin-needed
Assignee

Updated

a month ago
Keywords: checkin-needed

Not likely for 66 release but maybe 67 is possible.

Discussed today: a potential product requirement (unclear of feasibility): add the new string (forcing the new string to be re-translated) but consider adding logic to "fall back" to the old translated string instead of the new one if non-English not available.

And please consider breaking the patch into two to get strings started on translation and landed first.

Flags: needinfo?(dreams)
Assignee

Comment 5

a month ago

@Francesco In the event that the new string isn't yet fully localized is it possible to fallback to the old translated one instead of the new default english string? I don't see how I could do this in code.

Flags: needinfo?(francesco.lodolo)

(In reply to Petru-Mugurel Lingurar[:petru] from comment #5)

@Francesco In the event that the new string isn't yet fully localized is it possible to fallback to the old translated one instead of the new default english string? I don't see how I could do this in code.

Sorry, that's a technical question that I can't answer. Maybe existing Fennec developers have ideas.

Personally, I can't imagine a way to do that, given that the missing string will be available in the file (in English) to avoid breaking the build. The fallback is at build time, not at run-time.

Flags: needinfo?(francesco.lodolo)

Personally, I can't imagine a way to do that, given that the missing string will be available in the file (in English) to avoid breaking the build.

OK that makes sense. Thanks for the quick responses...

Then our best technique is still, as I understand it, land the string(s) as early as possible, even separate from the code changes.

(In reply to Devin Reams (dreams) from comment #7)

Then our best technique is still, as I understand it, land the string(s) as early as possible, even separate from the code changes.

Yes. Also knowing that we can't ship any updates to translation for 67 past May 1st.

Assignee

Updated

a month ago
Depends on: 1544840
Summary: Change Fennec about:addons' AMO link title to "Browse recommended Firefox Add-ons" and URL to AMO's featured Fennec extensions → Change Fennec about:addons' AMO link title to "Browse recommended Firefox Add-ons"
Assignee

Updated

a month ago
No longer depends on: 1544840
See Also: → 1544840
Assignee

Updated

a month ago
Keywords: checkin-needed
Attachment #9058604 - Attachment description: Bug 1544525 - Update about:addons's AMO link and title → Bug 1544525 - Update about:addons's AMO title

land the string(s) as early as possible, even separate from the code changes.

That sounds indeed like the best way forward.

Reporter

Comment 10

a month ago

Petru, sorry for the late change request, but the AMO team has new suggestions for the AMO link title and URL. Can you please update your patch to use this new title and URL?

  • Title = Browse Firefox's Recommended Extensions (instead of "Browse recommended Firefox Add-ons")
  • URL = https://addons.mozilla.org/firefox/collections/4757633/mob/
Flags: needinfo?(petru.lingurar)
Keywords: checkin-needed
OS: Unspecified → Android
Reporter

Comment 11

a month ago

(In reply to Francesco Lodolo [:flod] from comment #6)

@Francesco In the event that the new string isn't yet fully localized is it possible to fallback to the old translated one instead of the new default english string? I don't see how I could do this in code.

@ Francesco, what is the process for changing an existing string's wording? How do translators get notified that they should re-translate a string?

If we reword the addons.browseAll string instead of deleting it and adding the new addons.browseAll2 string, then not-yet-retranslated locales would still have their original translated value addons.browseAll=Browse all Firefox Add-ons. That would be better than falling back to the new untranslated English string addons.browseAll2=Browse Firefox's Recommended Extensions.

Flags: needinfo?(francesco.lodolo)

(In reply to Chris Peterson [:cpeterson] from comment #11)

@ Francesco, what is the process for changing an existing string's wording? How do translators get notified that they should re-translate a string?

You change the string ID, making it a brand new string that needs to be localized from scratch.

If we reword the addons.browseAll string instead of deleting it and adding the new addons.browseAll2 string, then not-yet-retranslated locales would still have their original translated value addons.browseAll=Browse all Firefox Add-ons. That would be better than falling back to the new untranslated English string addons.browseAll2=Browse Firefox's Recommended Extensions.

They will never know the string changed. The source changed, but the string is still translated, no dashboard or tool will report it. New IDs is the only way to ensure a string is looked at and updated.

Flags: needinfo?(francesco.lodolo)
Reporter

Updated

a month ago
Summary: Change Fennec about:addons' AMO link title to "Browse recommended Firefox Add-ons" → Change Fennec about:addons' AMO link title and URL

(In reply to Petru-Mugurel Lingurar[:petru] from comment #5)

@Francesco In the event that the new string isn't yet fully localized is it possible to fallback to the old translated one instead of the new default english string? I don't see how I could do this in code.

IIRC, we've managed to do that in the past with DTDs and weirdo hacks and relying on ordering of stuff.

In properties, you could do something like:

If string2 is not en-US, use string2
If string2 is en-US and string1 is en-US, use string2
Otherwise use string1

That requires to hard-code the en-US values for the old and the new string in the code, and to keep the old string around, so you can get it reliably.

And ensure we will always show a localized title, even if we have to fallback
to the old already localized one.

Assignee

Updated

a month ago
Attachment #9058604 - Attachment is obsolete: true
Flags: needinfo?(petru.lingurar)
Assignee

Updated

a month ago
Duplicate of this bug: 1544840
Attachment #9058875 - Attachment description: Bug 1544525 - Update about:addons's AMO title; r?Pike → Bug 1544525 - Update about:addons's AMO title; r?Pike, JanH
Assignee

Updated

a month ago
Keywords: checkin-needed

Comment 17

a month ago

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/176a74bf9fe2
Update about:addons's AMO title; r=Pike,JanH
https://hg.mozilla.org/integration/autoland/rev/80d7bc088091
Update about:addons's AMO link; r=AndreiLazar

Keywords: checkin-needed
Assignee

Updated

a month ago
Flags: qe-verify+

Comment 18

a month ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Reporter

Updated

a month ago
Depends on: 1545838
Reporter

Comment 19

a month ago

Petru, can you please request uplift for your AMO fixes to Fennec 67 Beta?

We will also want to uplift Andrei's AMO URL fix in bug 1545838. Your fixes will need to land on Beta before Andrei's.

Flags: needinfo?(petru.lingurar)

Comment on attachment 9058875 [details]
Bug 1544525 - Update about:addons's AMO title; r?Pike, JanH

Beta/Release Uplift Approval Request

  • User impact if declined: Outdated AMO experience in about:addons
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open about:addons
    Confirm the text for the AMO title is changed now to "Browse Firefox’s Recommended Extensions"
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): A string update covered by an updated test-case.
  • String changes made/needed: This patch contains the string update.
Flags: needinfo?(petru.lingurar)
Attachment #9058875 - Flags: approval-mozilla-beta?

Comment on attachment 9058881 [details]
Bug 1544525 - Update about:addons's AMO link; r?AndreiLazar

Beta/Release Uplift Approval Request

  • User impact if declined: Outdated AMO experience in about:addons
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open about:addons
    Press "Browse Firefox’s Recommended Extensions"
    Confirm that the page opened is valid and the url is different than the old "https://addons.mozilla.org/%LOCALE%/android/"
    (Another uplift - bug 1545838 is requested which overwrites the url that this patch initially modified)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): A single URL change.
  • String changes made/needed: --
Attachment #9058881 - Flags: approval-mozilla-beta?

Verified as fixed on latest Nightly build (68.0a1).
Devices:

  • Google Pixel (Android 9)
  • Samsung Galaxy Note 8 (Android 9)
  • Xiaomi Mi4i (Android 5.0.2)
Flags: qe-verify+

Comment on attachment 9058875 [details]
Bug 1544525 - Update about:addons's AMO title; r?Pike, JanH

Low risk and P1, uplift approved for 67 beta 14, thanks.

Attachment #9058875 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9058881 [details]
Bug 1544525 - Update about:addons's AMO link; r?AndreiLazar

Uplift approved for 67 beta 14, thanks.

Attachment #9058881 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

29 days ago
Regressions: 1546936

Hello,

I have verified the issue on Beta 67.0b14 using OnePlus A3000 (Android 6.0.1) and Samsung Galaxy S8+ (Android 8.0.0).

The text in the about:addons section is changed and redirects correctly.

Due to my findings, I'll mark this issue as verified in Firefox 67.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.