Closed Bug 1545810 Opened 1 year ago Closed 1 year ago

windows/aarch64 - web platform test chunk investigation

Categories

(Testing :: web-platform-tests, defect)

ARM64
Windows 10
defect
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: egao, Assigned: egao)

References

Details

Attachments

(1 file)

web platform tests often experience issues with certain chunks when run with the standard 12 chunks on windows10-aarch64. It leads to an exception of the task, then retries.

Investigate why this occurs:

  • chunk numbers?
  • particular test?
Component: Web Audio → web-platform-tests
OS: Unspecified → Windows 10
Product: Core → Testing
Hardware: Unspecified → ARM64

The following is the preliminary result of the investigation.

Chunk sizes were altered for different runs to investigate and isolate the following:

  • is the inherently the name 'wpt11' that is the issue?
  • is it a certain test that is the issue?
  • could it be the timing?

Chunk counts

chunk 120

chunk 71 failed

chunk 48

chunk 23 failed

chunk 24

chunk 11 failed

chunk 20

chunk 11 failed

It is possible to glean from this that the problem is not with the 'wpt11' chunk name but rather the test.

Test file

Analyzing the contents of the failed chunk from wpt11, wpt23 and wpt71 shows the following:

wpt11 ∩ wpt23 = 130 tests:

/FileAPI/FileReaderSync.worker.html
/FileAPI/fileReader.html
/FileAPI/historical.https.html
/FileAPI/idlharness.html
/FileAPI/idlharness.worker.html
/FileAPI/unicode.html
/client-hints/accept_ch.http.html
/client-hints/accept_ch.tentative.https.html
/client-hints/accept_ch.tentative.sub.https.html
/client-hints/accept_ch_lifetime_cross_origin_iframe.tentative.sub.https.html
/client-hints/accept_ch_lifetime_same_origin_iframe.tentative.https.html
/client-hints/accept_ch_lifetime_subresource.tentative.https.html
/client-hints/accept_ch_malformed_header.https.html
/client-hints/http_equiv_accept_ch.tentative.http.html
/client-hints/http_equiv_accept_ch.tentative.https.html
/client-hints/http_equiv_accept_ch.tentative.sub.https.html
/client-hints/http_equiv_accept_ch_lifetime_cross_origin_iframe.tentative.sub.https.html
/client-hints/http_equiv_accept_ch_lifetime_same_origin_iframe.tentative.https.html
/client-hints/http_equiv_accept_ch_lifetime_subresource.tentative.https.html
/client-hints/http_equiv_accept_ch_malformed_header.tentative.https.html
/client-hints/image-with-dpr-header.html
/client-hints/sec-ch-ua.http.html
/client-hints/sec-ch-ua.https.html
/css/css-animations/AnimationEffect-getComputedTiming.tentative.html
/css/css-animations/CSSAnimation-animationName.tentative.html
/css/css-animations/CSSAnimation-canceling.tentative.html
/css/css-animations/CSSAnimation-effect.tentative.html
/css/css-animations/CSSAnimation-finished.tentative.html
/css/css-animations/CSSAnimation-getCurrentTime.tentative.html
/css/css-animations/CSSAnimation-id.tentative.html
/css/css-animations/CSSAnimation-pausing.tentative.html
/css/css-animations/CSSAnimation-playState.tentative.html
/css/css-animations/CSSAnimation-ready.tentative.html
/css/css-animations/CSSAnimation-startTime.tentative.html
/css/css-animations/CSSPseudoElement-getAnimations.tentative.html
/css/css-animations/Document-getAnimations.tentative.html
/css/css-animations/Element-getAnimations-dynamic-changes.tentative.html
/css/css-animations/Element-getAnimations.tentative.html
/css/css-animations/KeyframeEffect-getKeyframes.tentative.html
/css/css-animations/KeyframeEffect-target.tentative.html
/css/css-animations/animation-iteration-count-calc.html
/css/css-animations/animationevent-interface.html
/css/css-animations/animationevent-marker-pseudoelement.html
/css/css-animations/animationevent-pseudoelement.html
/css/css-animations/animationevent-types.html
/css/css-animations/computed-style-animation-parsing.html
/css/css-animations/event-dispatch.tentative.html
/css/css-animations/event-order.tentative.html
/css/css-animations/historical.html
/css/css-animations/idlharness.html
/css/css-animations/inheritance.html
/css/css-animations/pending-style-changes-001.html
/css/css-animations/style-animation-parsing.html
/css/css-text/overflow-wrap/overflow-wrap-anywhere-span-002.html
/css/css-text/overflow-wrap/overflow-wrap-break-word-span-002.html
/css/css-text/overflow-wrap/word-wrap-alias.html
/media-source/SourceBuffer-abort-readyState.html
/media-source/SourceBuffer-abort-removed.html
/media-source/SourceBuffer-abort.html
/media-source/URL-createObjectURL-null.html
/media-source/URL-createObjectURL-revoke.html
/media-source/URL-createObjectURL.html
/media-source/idlharness.any.worker.html
/media-source/idlharness.any.html
/media-source/mediasource-activesourcebuffers.html
/media-source/mediasource-addsourcebuffer-mode.html
/media-source/mediasource-addsourcebuffer.html
/media-source/mediasource-append-buffer.html
/media-source/mediasource-appendbuffer-quota-exceeded.html
/media-source/mediasource-appendwindow.html
/media-source/mediasource-attach-stops-delaying-load-event.html
/media-source/mediasource-avtracks.html
/media-source/mediasource-buffered.html
/media-source/mediasource-changetype-play.html
/media-source/mediasource-changetype.html
/media-source/mediasource-closed.html
/media-source/mediasource-config-change-mp4-av-framesize.html
/media-source/mediasource-config-change-mp4-av-video-bitrate.html
/media-source/mediasource-config-change-mp4-v-bitrate.html
/media-source/mediasource-config-change-mp4-v-framerate.html
/media-source/mediasource-config-change-mp4-v-framesize.html
/media-source/mediasource-config-change-webm-a-bitrate.html
/media-source/mediasource-config-change-webm-av-audio-bitrate.html
/media-source/mediasource-config-change-webm-av-framesize.html
/media-source/mediasource-config-change-webm-av-video-bitrate.html
/media-source/mediasource-config-change-webm-v-bitrate.html
/media-source/mediasource-config-change-webm-v-framerate.html
/media-source/mediasource-config-change-webm-v-framesize.html
/media-source/mediasource-detach.html
/media-source/mediasource-duration-boundaryconditions.html
/media-source/mediasource-endofstream-invaliderror.html
/media-source/mediasource-endofstream.html
/media-source/mediasource-errors.html
/media-source/mediasource-getvideoplaybackquality.html
/media-source/mediasource-invalid-codec.html
/media-source/mediasource-is-type-supported.html
/media-source/mediasource-liveseekable.html
/media-source/mediasource-multiple-attach.html
/media-source/mediasource-play-then-seek-back.html
/media-source/mediasource-play.html
/media-source/mediasource-preload.html
/media-source/mediasource-remove.html
/media-source/mediasource-removesourcebuffer.html
/media-source/mediasource-seek-beyond-duration.html
/media-source/mediasource-seek-during-pending-seek.html
/media-source/mediasource-seekable.html
/media-source/mediasource-sequencemode-append-buffer.html
/media-source/mediasource-sourcebuffer-mode-timestamps.html
/media-source/mediasource-sourcebuffer-mode.html
/media-source/mediasource-sourcebuffer-trackdefaults.html
/media-source/mediasource-sourcebufferlist.html
/media-source/mediasource-timestamp-offset.html
/media-source/mediasource-trackdefault.html
/media-source/mediasource-trackdefaultlist.html
/mixed-content/audio-tag/http-csp/same-host-https/top-level/no-redirect/allowed/allowed.https.html
/mixed-content/worklet-paint-data-import/no-opt-in/same-host-https/top-level/keep-scheme-redirect/allowed/allowed.https.html
/payment-method-basic-card/historical.https.html
/payment-method-basic-card/idlharness.window.html
/payment-method-basic-card/payment-request-canmakepayment-method.https.html
/referrer-policy/no-referrer-when-downgrade/meta-referrer/cross-origin/http-http/a-tag/no-redirect/insecure-protocol.http.html
/referrer-policy/no-referrer/meta-referrer/same-origin/http-http/script-tag/swap-origin-redirect/generic.http.html
/referrer-policy/origin/http-rp/cross-origin/http-https/iframe-tag/swap-origin-redirect/generic.http.html
/referrer-policy/same-origin/meta-referrer/same-origin/http-https/img-tag/swap-origin-redirect/same-origin-insecure.http.html
/referrer-policy/strict-origin-when-cross-origin/attr-referrer/same-origin/http-https/script-tag/swap-origin-redirect/upgrade-protocol.http.html
/referrer-policy/strict-origin/meta-referrer/cross-origin/http-https/img-tag/no-redirect/upgrade-protocol.http.html
/referrer-policy/unsafe-url/meta-referrer/same-origin/http-https/img-tag/no-redirect/generic.http.html
/referrer-policy/unset-referrer-policy/http-rp/cross-origin/http-http/img-tag/no-redirect/insecure-protocol.http.html
/referrer-policy/unset-referrer-policy/http-rp/same-origin/http-http/img-tag/swap-origin-redirect/insecure-protocol.http.html
/webaudio/the-audio-api/the-oscillatornode-interface/ctor-oscillator.html
/webaudio/the-audio-api/the-oscillatornode-interface/detune-limiting.html

(wpt11 ∩ wpt23) ∩ wpt71 = also the same 130 tests.

It would appear the tests that are causing a crash is one of the 130 listed.

Further investigation is inconclusive in that it failed to pinpoint the test file(s) that cause the failure, but points to media-source being the culprit.

Attachment #9060616 - Attachment description: Bug 1545810 - disable tests in testing/web-platform/meta/media-source/ on windows10-aarch64 due to crashes → Bug 1545810 - disable tests in testing/web-platform/meta/media-source/ on windows10-aarch64 that cause task to abort
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ce05675c447
disable tests in testing/web-platform/meta/media-source/ on windows10-aarch64 that cause task to abort r=jmaher
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.