Closed Bug 1547820 Opened 8 months ago Closed 4 months ago

windows/aarch64 - testing/web-platform/tests/media-source crashes on ARM64

Categories

(Core :: Audio/Video: Playback, defect)

ARM64
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla70
Tracking Status
firefox70 --- fixed

People

(Reporter: egao, Assigned: egao, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Try runs of web-platform-tests on windows10-aarch64 often enters retry state.

Investigation in https://bugzilla.mozilla.org/show_bug.cgi?id=1545810#c4 revealed with high confidence that media-source subsuite is the culprit for the failure on Try. With the media-source subsuite disabled, web-platform-tests does not experience the retry state.

I was able to reproduce the failure with locally available windows10-aarch64 hardware:

21:33:21     INFO - Content-Length response header: 54372242
21:33:21     INFO - Bytes received: 54372242
21:41:01     INFO - Running post-action listener: _resource_record_post_action
21:41:01     INFO - Running post-action listener: find_tests_for_coverage
21:41:01     INFO - Running post-action listener: find_tests_for_verification
21:41:01     INFO - Running post-action listener: set_extra_try_arguments
21:41:01     INFO - Running post-action listener: setup_coverage_tools
21:41:01     INFO - [mozharness: 2019-04-03 21:41:01.316000Z] Finished download-and-extract step (failed)
21:41:01    FATAL - Uncaught exception: Traceback (most recent call last):
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\base\script.py", line 2089, in run
21:41:01    FATAL -     self.run_action(action)
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\base\script.py", line 2028, in run_action
21:41:01    FATAL -     self._possibly_run_method(method_name, error_if_missing=True)
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\base\script.py", line 1983, in _possibly_run_method
21:41:01    FATAL -     return getattr(self, method_name)()
21:41:01    FATAL -   File "mozharness/scripts/web_platform_tests.py", line 310, in download_and_extract
21:41:01    FATAL -     suite_categories=["web-platform"])
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\mozilla\testing\testbase.py", line 473, in download_and_extract
21:41:01    FATAL -     self._download_test_packages(suite_categories, extract_dirs)
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\mozilla\testing\testbase.py", line 374, in _download_test_packages
21:41:01    FATAL -     extract_dirs=unpack_dirs)
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\base\script.py", line 738, in download_unpack
21:41:01    FATAL -     function(**kwargs)
21:41:01    FATAL -   File "c:\mozilla-build\mozharness\mozharness\base\script.py", line 645, in deflate
21:41:01    FATAL -     t.extractall(path=extract_to)
21:41:01    FATAL -   File "c:\mozilla-build\python\lib\tarfile.py", line 2081, in extractall
21:41:01    FATAL -     self.extract(tarinfo, path)
21:41:01    FATAL -   File "c:\mozilla-build\python\lib\tarfile.py", line 2118, in extract
21:41:01    FATAL -     self._extract_member(tarinfo, os.path.join(path, tarinfo.name))
21:41:01    FATAL -   File "c:\mozilla-build\python\lib\tarfile.py", line 2194, in _extract_member
21:41:01    FATAL -     self.makefile(tarinfo, targetpath)
21:41:01    FATAL -   File "c:\mozilla-build\python\lib\tarfile.py", line 2234, in makefile
21:41:01    FATAL -     with bltn_open(targetpath, "wb") as target:
21:41:01    FATAL - IOError: [Errno 13] Permission denied: 'c:\\mozilla-build\\build\\tests\\web-platform\\tests\\fonts\\Ahem.ttf'

:drno - letting you know that I've had to disable this particular subsuite due to retry errors it was causing for the wpt11 chunk. I spent quite a bit of time investigating, attempting to narrow down the cause of the retry but was unable to do so.

My suspicion is that the retry error state can be entered from a number of ways, and depends on a chain of test cases. My investigation is recorded at 1545810.

Flags: needinfo?(drno)
Blocks: 1533880
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f977db21c7ca
re-enable media-source wpt tests on windows10-aarch64 r=intermittent-reviewers,jmaher
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70
You need to log in before you can comment on or make changes to this bug.