Closed Bug 1545814 Opened 5 months ago Closed 5 months ago

Send "intent to deprecate" for old proxy API

Categories

(WebExtensions :: General, task, P1)

task

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mconca, Assigned: mconca)

References

(Blocks 1 open bug)

Details

The deprecation of the old proxy API needs to be communicated via an email to the dev-addons mailing list.

Assignee: nobody → mconca
Priority: -- → P1

The following message was sent to the dev-addons mailing list on 19-April-2019:


WHAT
The following WebExtensions API are being deprecated:

  • browser.proxy.register()
  • browser.proxy.unregister()
  • browser.proxy.onProxyError()

WHY
The proxy.register() API use a proprietary PAC script because, at the time it was implemented, the proxy filter system was synchronous. It does not implement the standard PAC API, so normal PAC scripts (typically found in enterprise environments) do not work with this API. Now that the asynchronous proxy.onRequest() API is available, as well as the proxy.settings() API for controlling global Firefox proxy settings, the original API are being deprecated in order to decrease the cost of maintenance for the WebExtensions API.

The proxy.onProxyError() API was replaced by the proxy.onError() API which has been available since Firefox 60. The MDN documentation was updated to reflect this, but the API was never actually removed from Firefox.

WHEN
These three API will be deprecated with the release of Firefox 71, currently scheduled for December 2019.

ACTION REQUIRED
Developers using any of the three deprecated API in their extension should migrate to a supported API as soon as possible.

The status of the deprecation process can be followed on bugzilla [1].

Mike Conca
Product Manager, Firefox WebExtensions

​[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1545811​

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.