Closed Bug 1546147 Opened 5 months ago Closed 5 months ago

ghost text box appears in One-Click Search Engines list of about:preferences

Categories

(Firefox :: Preferences, defect, P3)

x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- wontfix
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: alice0775, Assigned: Gijs)

References

Details

(Whiteboard: [dupe me])

Attachments

(2 files)

Attached image image.png

Steps to Reproduce:

  1. about:preferences
  2. Search
  3. Double click to edit keyword
  4. General
    --- Browser console shows the following error
  5. Search and scroll to One-Click Search Engines
    --- ghost text box appears
  6. Click a search engine
    --- ghost text box is still there

Actual Results:
Browser console shows the following error

TypeError: aEvent is undefined search.js:282:18
onInputBlur chrome://browser/content/preferences/in-content/search.js:282
handleEvent chrome://browser/content/preferences/in-content/search.js:241
TypeError: this.view is null tree.js:1152:9
stopEditing chrome://global/content/elements/tree.js:1152
setupEventListeners chrome://global/content/elements/tree.js:693

And ghost text box appears

Expected Results:
No error, no ghost text box

Thanks for providing all the relevant info (esp. error messages) in comment #0, looks like fixing this is pretty trivial.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P3
Duplicate of this bug: 1532633
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d7ee53a44d58
fix broken search keyword textbox when switching categories, r=vporof
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

I have managed to reproduce this issue on an affected Firefox 67.0b12 build using Windows 10 x64 by following the STR from comment 0.

This issue is verified fixed using Firefox 68.0b7 on the following OSes: Windows 10 x64, Ubuntu 18.04 x64, Windows 7 x64, macOS 10.13.6.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.