Closed Bug 1546974 Opened 3 years ago Closed 2 years ago

Saved passwords between ro-ro.facebook.com and www.facebook.com are not autofilled

Categories

(Toolkit :: Password Manager: Site Compatibility, defect)

Desktop
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1120684
Tracking Status
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: danibodea, Unassigned)

Details

Attachments

(2 files)

Note

  • When the user logs into ro-ro.facebook.com and saves the credentials and then goes to www.facebook.com, he will notice that the credentials are not being auto-filled as the site is being seen as a different one.

Affected versions

  • Nightly v68.0a1
  • Beta v67.0b13
  • Release v66.0.3

Affected platforms

  • All

Preconditions
You may need to be on Romanian territory or use VPN.

Steps to reproduce

  1. Go to www.facebook.com
  2. Connect with an account and save the credentials.
  3. Log out.
  4. Go to ro-ro.facebook.com.

Expected result

  • Credentials should be auto-filled.

Actual result

  • Credentials are not being auto-filled.

Additional details:

  • www.facebook.com and ro-ro.facebook.com are seen as two different sites by the browser.

Bug 589628 is fixing this for autocomplete… Bug 1120684 is the solution for autofill but that isn't on the roadmap anytime soon.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120684

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Hi,

Following the steps, I have managed to reproduce this issue on latest FF release (66.0.3), latest Nightly build (68.0a1 (2019-04-29)) using Windows10.
But if access ro-ro.facebook.com first, enter and save credentials, then go to www.facebook.com credentials are auto-filled.

I attach the logs here for both situations.

I don't think the initial dupe was good for this case, since this is about subdomain/etld+1 support, which meanwhile has been implemented and shipped, removing the dupe and marking WFM as this was fixed by bug 1563330 and bug 589628

Status: RESOLVED → VERIFIED
Resolution: DUPLICATE → WORKSFORME

Reverting the changes done in comment 5, this is about autofill and not autocomplete, as I've missread.

Status: VERIFIED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: WORKSFORME → DUPLICATE
Summary: Saved passwords between ro-ro.facebook.com and www.facebook.com are incompatible → Saved passwords between ro-ro.facebook.com and www.facebook.com are not autofilled
Duplicate of bug: 1120684
You need to log in before you can comment on or make changes to this bug.