Closed Bug 1547050 Opened 4 months ago Closed 4 months ago

builtin search extensions are not loaded in safe mode

Categories

(Firefox :: Search, defect, P1, minor)

68 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: alice0775, Assigned: mixedpuppy)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [dupe me])

Attachments

(1 file)

Reproducible: always

Steps To Reproduce:

  1. Start Nightly68.0a1 with safe mode

  2. Type text in address bar or Search bar
    --- observe One-off search button icon

  3. Open about:preferences#search
    --- observe One-off search button icon

Actual Results:
No icon

Expected Results:
Icon hould be shown

Whiteboard: [dupe me]
Severity: normal → minor

Also affects the address bar. I strongly suspect this is due to the built-in Search WebExtensions being partially(?) disabled in safe mode.

Summary: One-off search button icon is missing in safe-mode → One-off search buttons are missing icons in safe mode

(In reply to Mark Banner (:standard8) from comment #1)

Also affects the address bar. I strongly suspect this is due to the built-in Search WebExtensions being partially(?) disabled in safe mode.

Not sure whether this would be a release blocker, but it's a regression nonetheless. Shane, what are your thoughts here? Is this something we'd like to change AddonManager behavior for?

Flags: needinfo?(mixedpuppy)

ISTM that searchservice should just detect safe mode on startup, and rely only on its cache in that case. Presumably firefox wouldn't be starting a new profile in safe mode. Otherwise, we probably have to make some exception for built-in extension. I'd like input from aswan on that.

Flags: needinfo?(mixedpuppy) → needinfo?(aswan)
Assignee: nobody → mixedpuppy
Priority: -- → P1
Summary: One-off search buttons are missing icons in safe mode → builtin search extensions are not loaded in safe mode
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca33e95075c3
support builtin extensions in safemode r=aswan
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.