Closed Bug 1547269 Opened 6 months ago Closed 4 months ago

Don't put LLVM in $PATH since we now prefer .mozbuild

Categories

(mozilla.org :: MozillaBuild, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jesup, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

We added detection of system-installed LLVM for windows in bug 1238251; since we now use .mozbuild and pull clang from there for windows (or want to), if this adds LLVM from the system (Program Files (x86)) it breaks builds and uses the wrong LLVM/clang.

Bug 1238251 was OK in its time, when anything related to LLVM on Windows was a personal customization that you had to set up explicitly. Presumably at that point you were aware of what did and didn't work, etc.

But nowadays, with so many build pieces defaulting to LLVM, we should really prefer .mozbuild because it often contains compiler patches that our tree requires. People who aren't tinkering with compilers shouldn't have to think about whether their system LLVM is appropriate or not; things should Just Work by default.

Bug 1519954 prioritized .mozbuild over $PATH, so, practically speaking, this is fixed.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME

This was fixed in bug 1253212.

Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.